6

When i export to pdf from QGIS the polygons become rounded or bloated. This image is a printscreen from the workspace in QGIS: enter image description here This image is a printscreen from the pdf (size A3 zoomed in 800%): enter image description here Although it's zoomed in alot it's noticable when fullscreen. The map im trying to make is size A3 so the details can be seen. Is there any way to keep the details as shown in the first picture? I have tried to uncheck the "simplify geometry" in the rendering tab for the layer, but without effect. The resault is somewhat better when changing the layout from A3 to something bigger like A1 or A0, but it's an annoying workaround because of scales.

  • 2
    looks like maybe a border thickness is being changed, possibly the scale is being adjusted during export and altering the line width. – TDavis Sep 25 '17 at 19:36
  • 1
    Did you enable scale-based rendering in style properties ? – Hugo Roussaffa - GeoDatup Sep 25 '17 at 20:03
7

Try setting the thickness of the borders of the polygons a bit smaller, in millimeter and maybe change the join style. If you set it too high and on bevel or rounded, the rounded factor you can set in the layer properties can be seen.

You can also choose to remove the borders of your polygons (style "no-pen")

no-pen

To make sure what will be the rendered layer, try putting the composer map scale into your map workspace and lock the scale, then zoom in and see.

lock scale

  • Thank you! It was the borders of the polygons that was the problem, they were too thick – Andreas Sep 25 '17 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.