2

QGIS has been very good about prompting me to update. Not this time. I run QGIS 2.18.12 on Win10. From reading this board I realize that 2.18.13 has been out for at least a week. Not only does QGIS (which I run daily) not prompt me to update, but the Version Information panel states that 2.18.12 is the current version ...

QGIS Version Information panel screenshot

... whereas qgis.org says otherwise. Why is that?

QGIS website screenshot

[UPDATE] Coincidentally (or not), about an hour after my original post, the issue resolved itself -- i.e., the Version Information panel knew that 2.18.13 was available, and the yellow update notification message appeared in the status bar. Still unsure what happened and why, so I'll leave this open for now. Maybe someone will offer insight into this mystery.

  • 1
    From Settings > Options > General, is the Check QGIS version at startup option checked? – Joseph Sep 26 '17 at 13:15
  • Yes, it is checked. – Atanas Entchev Sep 26 '17 at 13:19
  • Could it be a firewall issue? The firewall somehow preventing QGIS from making the call? – Atanas Entchev Sep 26 '17 at 13:20
  • I can access the repository. Strange, indeed. Thanks for your suggestions. – Atanas Entchev Sep 26 '17 at 13:56
3

according to this code QGIS checks for a value embedded in the file at https://ubuntu.qgis.org/version.txt. If the version number is greater than your current installation, you see the prompt.

I suspect what happened is that either

  • there was a slight delay between the website being updated and this file being updated on the server
  • perhaps the QGISNetworkManager has the old file contents cached somewhere, and restarting QGIS cleared this out of the cache, and it noticed the updated number.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.