I have a problem in calculating areas in QGIS. The data is in projection EPSG 25832 (ETRS89/UTM32). According to the cadastre, the feature has an area of 34025 m². If i measure the area of this feature with the measurement-tool it says 33920 m² (minus 105 m²). If i lable the feature with $area it says 34034 m² (plus 8 m²). In our CAD-program GEOgraf we have a setting called 'Maßstabsreduktion', i think in english it could be the projection scale factor or scale distortion or scale reduction. We have the problem that we are at the edge of zone 32 to zone 33. So we have distortions in area and lenght. In GEOgraf we have to set this parameter to 0.9996 instead of 1.0000 and the program calculate a reduction in the area and in the lenght. If i disable this parameter in GEOgraf i get the same area, QGIS calculate for the label of this feature (34034 m²). If i enable this parameter in GEOgraf i get the area given by the cadastre.

So my question is: Is there a possibility to give QGIS such a parameter somewhere?

  • One way is to créateur your own projection system to get better precision of your region of interest. – Hugo Roussaffa - GeoDatup Sep 27 '17 at 13:20
  • Take a look at Project -> Project Properties -> General -> Measurements. You can choose between certain ellipsoides and none/planimetric. The cadastre may use that, while QGIS calculates more accurate on the bended ellipsoid surface. – AndreJ Sep 27 '17 at 18:22
  • Ask from the cadastre authority how they have measured and recorded the area, and if the area is GIS area or manually saved area in the registry. Cadasters have very long history and stored areas do not necessarily correspond with computed areas. Landowner may have bought 20 hectares land 200 years ago and borders were marked into field with landmarks. If you now measure area by the landmarks you will not get 20000 square meters but that can still be the official area in cadastre. What is sure is that the native projection of the cadastre is not any UTM zone. – user30184 Sep 28 '17 at 6:05
  • @AndreJ Thanks, now i know where to find this option... the correct ellipsoid is choosen. But i think the reason for the difference is the scale factor... with the use of the scale factor in GEOgraf the calculated area is the same as given by the cadastre. – Astrid Sep 28 '17 at 8:09
  • @user30184 Thanks for your answer. I know, if you have an old parcel and you measure the area now, that you get another area than 200 years ago. This land parcel is rather new, partitioned 3 or 4 years ago with Tachymeter and GPS. So this shouldn't be the reason. – Astrid Sep 28 '17 at 8:17

The factor you are speaking of is the scale factor. And you do not have to set it as it is already used by this projection. The scale factor of 1,0000 was used for the old system. UTM does use a scale factor of 0,9996 because it uses 6° broad zones that are touching the earth surface at minimum and maximum of its zone. The old system used 3° zones with its touching point at the middle. To avoid larger distortions the new projection-system therefore uses this scale factor as far as i know.

  • Hey Matte, thanks for your answer. I use the high accuracy transformation grid of the state Saxony-Anhalt for the data and not the "global" beta2007-grid for whole Germany. – Astrid Sep 28 '17 at 6:47
  • And you're right, the accuracy of 0,02% is really high. If i understand you correctly, QGIS should use the scale factor automatically for this projection? So is there a parameter for this in the projection defintion? But what i doesn't understand: If QGIS uses the scale factor, why do i get an calculated area, which is the same like the calculated area in GEOgraf with scale factor disabled? Looks to me that QGIS doesn´t use the scale factor. – Astrid Sep 28 '17 at 7:21
  • @Matte do you have any reference for the use of beta2007 in QGIS for EPSG:25832? AFAIK the grid is only used for transformation from DHDN based CRS to ETRS89 (but QGIS uses 7parms Helemert for that). Apart from that EPSG:25832 covers much more than Germany. Height adjustment can be done with DHHN, but thats still outside QGIS. – AndreJ Sep 28 '17 at 9:26
  • @Astrid if you run gdalsrsinfo EPSG:25832 in the OSGEO4W shell terminal, you see that the scale factor of 0.9996 is applied automatically. It hides in the ' +utm'. if you want 1.000, you need to build a custom tmerc projection instead. – AndreJ Sep 28 '17 at 9:37
  • @Andre Thanks, i mixed that up while writing. As there is no transformation going on here and the higher accuracy data is used it does not matter. I therefore also deleted the part about that. – Matte Sep 28 '17 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.