1

I've merged two polygons in QGIS, but I've been unable to rid myself of the excess boundaries from the old polygons that continue to exist inside the new one. The only boundaries I would like to keep are the outermost.enter image description here

The polygon in question is the green one. I've also tried using dissolve, but it hasn't helped.

  • Did you check for geometry errors? Dissolve would not work else. – AndreJ Feb 4 '18 at 6:54
1

It seems, that you merged two polygons into one layer, hence they are still individual polygons drawn on top op each other. You should be able to use the dissolve tool on your layer, and use the "dissolve all - do not use fields" option in that tool to get the correct result.

  • Is this the Dissolve function that can be found in the Geoprocessing menu? Just wondering cause the dissolve all option is simply labeled as "---Dissolve all---" and doesn't mention anything about not using fields. I tried using Geoprocessing --> Dissolve ---> Dissolve all but it produced a new polygon with the same problem – GISChinchilla Sep 28 '17 at 10:35
  • Yes, that is the tool i would use. What version of QGIS are you using? could you possible upload a part of your dataset for me to explore? – Jack Sep 29 '17 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.