4

I cannot seem to Move Feature for PostGIS layers in QGIS 3 (2.99 43a9bc1) after I enabled editing as shown below.

enter image description here

Even though I can add features with the Add button, the Move Feature button is greyed out.

Does anyone know what might be the cause or how to fix it?

--EDIT--

Regarding the table, I do have the privileges as I am the owner of the db, and I just verified that I can create features in it. I also created a field called ogc_field because of prior issue with updating the table in question. Unable to update features in tables without FID: How to use gid field as the FID column with ogr/gdal python? .

ogc_fid | integer | not null default nextval('cfl.match_opl_prmatch_ex_pl62__p5_ogc_fid_seq'::regclass) | plain |

I don't know if this is sufficient for QGIS.

4
  • from my experience using the move feature will not work with a postgis table. save it as a geoJSON and it should work
    – ziggy
    Oct 4, 2017 at 17:51
  • move works, you need the correct privileges... Oct 4, 2017 at 18:27
  • @DPSSpatial ive tried it as a superuser and the tool was grayed out. but maybe you are correct
    – ziggy
    Oct 4, 2017 at 18:34
  • 1
    Primary Key is always a factor when editing PostGIS data in QGIS... @ziggy I always look for that first... Oct 4, 2017 at 21:17

2 Answers 2

7

Your user is lacking the UPDATE privilege on the layer.

PS: after granting it, you would need to re-open the project to see the changes.

4

Does your dataset have a primary key assigned? Even if its just an arbitrary OBJECTID, you need to have that to do any editing in QGIS.

1
  • This solved the issue for me! Jul 9, 2020 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.