2

I am using Terrascan to strip vegetation of some ASCII files to create a bare earth model and also to convert the ASCII txt file into a *las (1.2) file.

However, I have noticed that Terrascan (at least visually) seems to grid the imported ASCII data. (The same happens by the way if I convert the ASCII txt file to a *las file before bringing it into Terrascan for processing.)

When I overlay the *las output file with the original ASCII file, the point cloud doesn't "match" up anymore (looks gridded), even though it tells me the number of points remained the same.

It's an xyz + intensity text file.

-10.579645 -1.290032 2131.672373 38
-10.563637 -1.288739 2131.663733 63
-10.549061 -1.287559 2131.653909 117
-10.521391 -1.285341 2131.654799 135
-10.502604 -1.283827 2131.648390 136
-10.498481 -1.283476 2131.629982 139
-10.491604 -1.282907 2131.613836 145
-10.463584 -1.280661 2131.614927 148
-10.528760 -1.285806 2131.540132 137
-10.651209 -1.295494 2131.418934 130

I am exporting out of polyworks as a point cloud (x,y,z,i; and 6 digits after decimal point). No headers, simple text file. When I convert the file to *las (via LAStools), the structure of the file is preserved, but as soon as I import into Terrascan, the file appears 'gridded'. I am not sure if Microstation or Terrascan import settings are screwing with the file. The original txt file is small coordinate numbers (not georeferenced yet).

My problem is that I will have to go to Terrascan eventually for the 'vegetation removal', so I need to find out what's causing the gridding.

  • 1
    What is the exact command in LAS2LAS? I don't know about polyworks but have used LasTools. If you're using -auto_reoffset then what is the description in LasInfo? – Michael Stimson Oct 6 '17 at 0:25
  • I am using the txt2las.exe through ArcToolbox. I am not sure about the settings... I didn't change any parameters, just did a straight conversion and like I said, the same happens in Terrascan with the txt and las file. They're a point cloud before import and when I import them, they appear gridded. I didn't see any parameters in Terrascan that I could change to see if it makes a difference. It must have something to do with it being a txt file or not an original las file (because some airborne las file that I have come into Terrascan just fine). – Sandra Bond Oct 6 '17 at 0:35
  • 1
    What is the description with LasInfo? (start a command window and drag in LasInfo.exe from \lastools\bin then add a space and drag in your LAS file), there will be a line like scale factor x y z: 0.01 0.01 0.01 which will show how LAS2LAS has exported the file. – Michael Stimson Oct 6 '17 at 0:39
  • scale factor x y z : 0.0000001 0.0000001 0.01 (thanks for the instructions on how to pull this up) – Sandra Bond Oct 6 '17 at 0:44
  • 1
    That seems fine.. It's possible that it's rounding it to a projected coordinate system by default. You might need to use -epsg 4324 in your LAS2LAS, but not sure where in the toolbox to put that... I use command line, it's quicker to type it than to find the tool and fill in the boxes. You might like to project the LAS to UTM before opening in Terrascan. – Michael Stimson Oct 6 '17 at 0:56
1

To solve this, Terrascan coordinate resolution settings had to be changed to work with the unprojected data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.