2

I have an image (RGB) with a lot of NaN pixels (black) and I want them to have no color for visualization on a map.

My raster is derived surface reflectance values from Sentinel 2. After atmospheric correction I stacked the blue, green and red band in R and exported the rasterStack (.tif) to ArcGIS Pro for making a map of the RGB raster on a basemap.

I have added a basemap that cannot be seen due to the black color and when I click the pixels I also see that they have No Data (nan)

But I cant seem to get rid of the black color. When I look in Symbology, background and NoData already is set to No Color. When I try to change the color of No Data, it has no effect.

How can I make my black NaN pixels no color/transparent using ArcGIS Pro?

Edit: I have added a picture showing the edge of my raster against the basemap, and the information I get when I click a black pixel.

12
  • 1
    Probably they have no color but your background looks black. Check by placing a big colored polygon underneath.
    – user30184
    Oct 6 '17 at 7:57
  • 2
    What makes you think that black color is No Data?
    – FelixIP
    Oct 6 '17 at 8:17
  • 1
    In all the years I've been using raster datasets I have never seen ArcMap or the new Pro return the value "nan" for a NoData cell. Edit your question and describe your raster format. Where did it come from, what processing had you done to it? Making NoData cells transparent should be a trivial task.
    – Hornbydd
    Oct 6 '17 at 9:09
  • 1
    So the source of the dataset you are attempting to display in Pro is this stacking process in R? I've never used R but that is where I would start looking, see if there is a parameter setting to define your NoData value.
    – Hornbydd
    Oct 6 '17 at 9:24
  • 1
    Suggest you read this thread.
    – Hornbydd
    Oct 6 '17 at 9:26
2

I know this question is from a few years back but incase anyone else has this issue ( I just did) you can get rid of the odd "nan" value by using the ArcGIS Pro raster calculator and multiplying the raster by 1. This turns the "nan" into NoData which is easy to get rid of.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.