2

I am trying to run QGIS 2.18.13 on Mac OS Sierra (10.12.4), but I'm having problems with SAGA and GRASS, at least from processing.

Here's what I did:

Installed QGIS from brew, but ended up having problems with the psycopg2 module. I tried to install it in various ways, but QGIS did not recognize it (perhaps I was doing something wrong, I don't know).

So I gave up homebrew and installed QGIS from the binary. Everything works, except SAGA and GRASS.

For SAGA, I get the following error:

2017-10-06T10:09:47 2 Problem with SAGA installation: installed SAGA version (2.2.3) is not supported

As for GRASS, when I try to run any algorithm from processing, I get the following:

Missing dependency. This algorithm cannot be run :-( This algorithm requires GRASS GIS 7 to be run. Unfortunately, it seems that GRASS GIS 7 is not installed in your system, or it is not correctly configured to be used from QGIS Click here to know more about how to install and configure GRASS GIS 7 to be used with QGIS

Note that I have already changed the GRASS path to /Applications/QGIS.app/Contents/MacOS/grass7 in Plugins/GRASS/GRASS options/general

In Processing/options/providers/GRASS GIS 7 I have:

  • GRASS7 folder : /Applications/QGIS.app/Contents/MacOS/
  • Msys folder : /Applications/QGIS.app/Contents/msys

After installing GRASS-7.0.app (which works fine) I tried:

  • GRASS7 folder : /Applications/GRASS-7.0.app/Contents/MacOS
  • Msys folder : /Applications/GRASS-7.0.app/Contents/msys

This didn't help. I've tried more or less everything I've found online, but nothing seems to work.

What am I doing wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.