I am having trouble with a machine running Arc GIS 9.3. When one tries to save an mxd, ArcMap stops responding and just hangs. I have even tried with an blank new mxd but the moment one clicks save it hangs without even opening the dialogue box that allows you to navigate to the location to save. Please help

  • A re-install followed by contacting your ESRI support would be the best suggestion based on the comments in these threads. There's something very broken with the install. – GIS-Jonathan May 21 '12 at 12:00

Have you tried to wait for few hours?

I have noticed similar behavior when I had broken links to network location which I used previously from ArcMap (open/save mxd). i.e. when taking laptop to new network environment. In such case you can take your laptop to previous net environment, try to use ArcMap there and open/save data from your local HDD. Or try to wait for quite a long time (few hours).

I hope it helps you!

  • Waiting for 2 hours and counting... – Klutch May 19 '12 at 9:13
  • Have you considered reinstalling ArcGIS ? – Alex Markov May 19 '12 at 9:32
  • re-installing would be the last resort because the particular user is rather busy and getting his free for a bit to do the reinstall is an issue – Klutch May 19 '12 at 11:41
  • Waiting till the next morning did the trick. – Klutch May 21 '12 at 15:32
  • So, the problem was with broken network locations ? – Alex Markov May 21 '12 at 15:46

Try using MXD Doctor - this can fix many issues with 'broken' MXDs. I assume that this particular MXD is now always giving you problems even after a fresh re-start.

Additional tangential info
I have had a similar issue too. In particular I have notice this happening, or sometimes a more graceful result of an error message as opposed just hanging, when I have let my machine go into extended hibernation with ArcMap open. It used to happen in 9.3x and still happens in 10.1. It also happens with a fresh install.

Another situation (and I don't know how Arc gets itself into this situation but I have seen it many times) is when Arc has not completely shut istelf down properly. It looks like it has but there is still an ESRI process alive behind the scenes. This can also impact your ability to edit files as well as save MXD documents because the locks persist. I can't tell if this is effecting you but it worth a look if/when you get any strange locks or MXD behaviour with Arc.

Press Ctrl+Shift+Esc to open the Windows Task Manager. Since you are trying to save, you should have at least one instance of ArcMap in the applications tab. Right click on it and select 'Go To Process'. Note how your current process is highlighted. Now click on 'Name' to sort the processes alphabetically. If you have another entry for ArcMap, a previous instance of ArcMap has failed to shut down correctly. Right-click on the ArcMap entry which is NOT highlighted (i.e. the one you are NOT trying to save and which ought to be dead anyway). Select 'End Process Tree'. This is different to End Process and it kills all dependent process associated with the un-dead ArcMap instance.

This pre-supposes you had at least one other ArcMap instance open prior to the one you are trying to save. I can't guarantee this is the solution to your problem but it can be a solution to many unexpected locks and errors, and is well worth a try if you really don't want to shut your machine down for some reason.

  • This is not editing an existing mxd, its a new installation and the user wants to create new mxds. – Klutch May 19 '12 at 11:44
  • 1
    If a new installation cannot create new MXDs, then there is something fundamentally wrong either with the machine or the installation. Assuming that the machine is not below spec, that really only leaves one sensible option, regardless of how busy your user is. Even if you do find a work around, I wouldn't trust the stability of the install. – MappaGnosis May 19 '12 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.