3

Currently I am facing a problem with our WMS Service on Geoserver. The data source is a big Image Pyramid with 5 levels covering Germany in EPSG:25832. For tiles outside the boundaries of the dataset Geoserver throws nullpointer exceptions if we request with tileSize:

    Request: getMap
    Angle = 0.0
    BaseUrl = xxxxxx
    Bbox = SRSEnvelope[357454.39991498 : 359900.3848201, 6066402.775276 : 6068848.7601811]
    BgColor = java.awt.Color[r=255,g=255,b=255]
    Buffer = 0
    CQLFilter = null
    Crs = PROJCS["ETRS89 / UTM zone 32N", 
  GEOGCS["ETRS89", 
    DATUM["European Terrestrial Reference System 1989", 
      SPHEROID["GRS 1980", 6378137.0, 298.257222101, AUTHORITY["EPSG","7019"]], 
      TOWGS84[0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0], 
      AUTHORITY["EPSG","6258"]], 
    PRIMEM["Greenwich", 0.0, AUTHORITY["EPSG","8901"]], 
    UNIT["degree", 0.017453292519943295], 
    AXIS["Geodetic longitude", EAST], 
    AXIS["Geodetic latitude", NORTH], 
    AUTHORITY["EPSG","4258"]], 
  PROJECTION["Transverse_Mercator", AUTHORITY["EPSG","9807"]], 
  PARAMETER["central_meridian", 9.0], 
  PARAMETER["latitude_of_origin", 0.0], 
  PARAMETER["scale_factor", 0.9996], 
  PARAMETER["false_easting", 500000.0], 
  PARAMETER["false_northing", 0.0], 
  UNIT["m", 1.0], 
  AXIS["Easting", EAST], 
  AXIS["Northing", NORTH], 
  AUTHORITY["EPSG","25832"]]
    Elevation = []
    Env = {}
    Exceptions = SE_XML
    FeatureId = null
    FeatureVersion = null
    Filter = null
    Filters = null
    Format = image/png
    FormatOptions = {}
    Get = true
    Height = 256
    Interpolations = []
    Layers = [org.geoserver.wms.MapLayerInfo@9e825f08]
    MaxFeatures = null
    Palette = null
    RawKvp = {FORMAT=image/png, REQUEST=GetMap, SRS=EPSG:25832, BBOX=357454.39991498,6066402.775276,359900.3848201,6068848.7601811, VERSION=1.1.1, STYLES=, SERVICE=WMS, WIDTH=256, HEIGHT=256, TRANSPARENT=FALSE, LAYERS=xx:xx}
    RemoteOwsType = null
    RemoteOwsURL = null
    Request = GetMap
    RequestCharset = UTF-8
    ScaleMethod = null
    Sld = null
    SldBody = null
    SldVersion = null
    SortBy = null
    SortByArrays = null
    SRS = EPSG:25832
    StartIndex = null
    StyleBody = null
    StyleFormat = sld
    Styles = [StyleImpl[ name=raster]]
    StyleUrl = null
    StyleVersion = null
    Tiled = false
    TilesOrigin = null
    Time = []
    Transparent = false
    ValidateSchema = false
    Version = 1.1.1
    ViewParams = null
    Width = 256
2017-10-06 17:11:04,858 DEBUG [org.geoserver.wms.map] - Writing png image ...
2017-10-06 17:11:04,891 INFO [org.vfny.geoserver.servlets] - OutputStream was successfully aborted.
2017-10-06 17:11:04,891 ERROR [org.geoserver.ows] - 
java.lang.NullPointerException
2017-10-06 17:11:04,891 DEBUG [org.geoserver.filters] - Compressing output for mimetype: application/vnd.ogc.se_xml;charset=UTF-8
2017-10-06 17:11:04,891 DEBUG [org.geoserver.security.filter.GeoServerSecurityContextPersistenceFilter$1] - SecurityContextHolder now cleared, as request processing completed

The error always occurs on the boundaries where the shape of the index is not exactly an rectangle:

enter image description here

With Open Layers the error looks like this:

enter image description here

I also found out, that two vendor parameters tiled and tilesOrigin have an impact on this error.

This request works:

?FORMAT=image%2Fpng&TRANSPARENT=FALSE&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&LAYERS=d&SRS=EPSG%3A25832&BBOX=281628.86785608,6110430.5035682,359900.3848201,6188702.0205323&WIDTH=256&HEIGHT=256&tiled=true&tilesOrigin=280000%2C5200000

And this doesn’t:

?FORMAT=image%2Fpng&TRANSPARENT=FALSE&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&LAYERS=d&SRS=EPSG%3A25832&BBOX=281628.86785608,6110430.5035682,359900.3848201,6188702.0205323&WIDTH=256&HEIGHT=256

So geoserver throws the exception because of the following missing parameters: &tiled=true&tilesOrigin=280000%2C5200000

We are running a geoserver 2.11.1

So, anybody any idea what the problem could be?

  • what happens if you use the builtin GWC tile end point instead (layer preview from the tiled layers menu page – Ian Turton Oct 6 '17 at 14:28
  • Yes, its working there, because the tilesOrigin and tiled parameters are added. But those parameters are geoserver-specific and not part of the ogc-specification. It should work without them. – aleho Oct 6 '17 at 14:31
  • please turn logging up and then try again and add the relevant part of the log file to the question – Ian Turton Oct 6 '17 at 14:43
  • ok - i extended the error message in original post – aleho Oct 6 '17 at 15:13
  • For anyone who wants to follow up: osgeo-org.atlassian.net/browse/GEOS-8327 – aleho Oct 10 '17 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.