2

I'm trying to merge or append layers with identical schemas. When I run the append arcpy function in a stand alone script (only the arcpy tool) it works but when I put it my complete script, the script completes but the output from the tool is empty.

I've tried using shapefiles, converting them to feature layers, and using the append and merge tool (both have the same output).

I'm not sure how to get around this and can't seem to find what could be causing this.

closed as off-topic by Midavalo Oct 11 '17 at 22:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions seeking help to debug/write/improve code must include the desired behavior, a specific problem or error and the shortest code necessary to reproduce it in the question itself. Providing a clear problem statement and evidence of a code attempt will help others to help you. See: How to create a Minimal, Complete, and Verifiable example." – Midavalo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    are you using the NO_TEST schema matching setting? – atxgis Oct 11 '17 at 21:12
  • 1
    Are you using Select Layer by Attributes/Location? It's possible you have an empty selection (0 selected) in the layer... try to Select Layer by Attributes with CLEAR_SELECTION before append/merge. Can you post your complete script, or at least the few lines before the merge/append? – Michael Stimson Oct 11 '17 at 21:24
  • Welcome to GIS SE! As a new user pleas take the tour to learn about our focused Q&A format. Please edit your question to include a snippet of your arcpy code so that we can see what you've actually tried and possibly see what the problem is. If you are getting error messages please also include those in your question. – Midavalo Oct 11 '17 at 22:18

Browse other questions tagged or ask your own question.