2

Consistent error upon adding a field to a shapefile and calculating area. Area is calculated correctly and is displayed in the current ArcMap 10.3.1 instance.

Upon software reload, the shapefile cannot be added due to a mismatch between the features and data, and the file is effectively broken.

This problem happens locally and with shapefiles we have sent clients when they perform the operation on their machines. The shapefiles are created with mapexport from AutoCAD.

1
  • 1
    Have you tried running check geometry before using calculate geometry? I've seen weird stuff in ex-CAD data when features have zero length arcs or segments, for example.
    – mkennedy
    Oct 12, 2017 at 17:46

1 Answer 1

1

It appears to be an issue with the projection either not being set properly or throwing off an error once the calculate geometry has been run on the shapefile.

You may want to use the repair bad geometry tool once you have completed the calculate geometry process to and simulate how your client is receiving the layer. Then test it out again to see if the error is still arising.

This post mentioned the use of projection when using the calculate geometry

Why is “calculate geometry” grayed out when data frame properties shows map units are in meters not degrees?

This is more of a general principle to ensure the projection information is suitable in a layer

Problem: The Calculate Geometry tool produces incorrect results for basemaps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.