4

I created a model that worked fine in QGIS 2.14. With help I included a script in the model that prevented the model from running unless a feature was selected. But after upgrading to 2.18 the model no longer runs unless I remove the script.

Model

enter image description here

Error

enter image description here

Script

enter image description here

The above does exactly what I want it to do in 2.14 so I don't understand why it won't in 2.18. I have a couple of other models that use the same script for the same purpose and have the same issue. I have tried this on my PC at home and on my work PCs and still have the same issue.

closed as off-topic by underdark Oct 14 '17 at 15:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    your script looks good, but I don't understand why you use the selectedfeature algorithm again (from the output of your script). No features are selected in this output and that's why you get the error. – Hugo Roussaffa - GeoDatup Oct 14 '17 at 14:04
  • Ah! I removed the selected feature algorithm and it works. Weird why it worked fine as it was in 2.14 but not in 2.18 though. I included that algorithm when I created the model on someone else's advice. Thanks for the helpful response. – webg Oct 14 '17 at 15:13
  • Can you reopen the question to post the answer I gave. DDon't understand why it's closed – Hugo Roussaffa - GeoDatup Oct 14 '17 at 22:43
  • Please always provide code and error messages as text rather than pictures. – PolyGeo Oct 19 '17 at 22:49