3

I've downloaded the .DEM files from the NASA SRTM30 dataset (found here) however trying to open these yields ERROR 4: "E140N90.DEM" is not recognized as a supported file format.

This is the the same while either using the windows binaries with python bindings and OSGeo4W shell. OSGeo is using GDAL 2.2.2 and USGSDEM files are listed under the supported formats in gdalinfo --formats

 ...
 USGSDEM -raster- (rwv): USGS Optional ASCII DEM (and CDED)
 ...

I've also tried opening the files in QGis, which has yielded the same result. So is there another way to open the files, or convert the files into a supported file format?

7
  • Please rename the extension from .DEM to .hgt and see if it can fix it.
    – Kazuhito
    Commented Oct 15, 2017 at 10:38
  • Same result as with .DEM
    – AlexVestin
    Commented Oct 15, 2017 at 10:40
  • 1
    Strange... I can open it in QGIS2.18.13... just to check: where did you store header file (HDR)?
    – Kazuhito
    Commented Oct 15, 2017 at 10:47
  • 2
    I had actually only downloaded the .DEM files, and so now I was able to open them with the .hdr files added!
    – AlexVestin
    Commented Oct 15, 2017 at 10:57
  • AlexVestin or @Kazuhito please consider adding this comment as an answer so the question can be marked as answered instead of staying open.
    – Kersten
    Commented Oct 16, 2017 at 14:53

1 Answer 1

3

My problem (as @Kazuhito pointed out) that I didn't download the accompanying Header files (.hdr). With the header files in the same directory as the .DEM, they are able to be opened

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.