7

In my attribute table for a shapefile, I am converting one field (Julian day) to another field (date) using the field calculator but I'm working with about 7.7 million rows. QGIS has been running for about 17 hours and is half way done. Is there a way to speed up this process? I have QGIS 2.14.19 Essen, not sure if upgrading to 2.18 would be faster.

10
  • 1
    Are you using a Linux-enabled toaster oven with a 60hz CPU? Is your data file on network-shared thumb drive? There's no way an update on a shapefile attribute should take more than 20-30 minutes, but there's no way to tell what's wrong with your process without being given details of the platform and data storage.
    – Vince
    Oct 15, 2017 at 16:40
  • 1
    What does "directly on my network" mean?
    – underdark
    Oct 15, 2017 at 19:21
  • 1
    Yes, by not having to open the attribute table it reduces burden on QGIS to refresh the table toward the end of the process. (sorry for this tardy reply btw.)
    – Kazuhito
    Oct 15, 2017 at 23:04
  • 1
    aaah, please see the answer provided by @ndawson.
    – Kazuhito
    Oct 16, 2017 at 0:31
  • 1
    So I tried it through layer properties and creating the new field went quickly but now I'm having problems saving the changes. I've left the program open for >1 hr and now QGIS isn't responding...
    – racheldeep
    Oct 16, 2017 at 3:28

1 Answer 1

9

Don't do it through the attribute table, or with any attribute tables open. Instead create new attributes directly though layer properties or via the field calculator from the main window.

Adding/deleting columns with attribute tables open is super-slow.

4
  • 2
    So I tried it through layer properties and creating the new field went quickly but now it's taking a very long time to save (an hour and counting)
    – racheldeep
    Oct 16, 2017 at 1:41
  • Are you sure you didn't have any open attribute tables (maybe hidden behind the main window) when you added the attribute/saved?
    – ndawson
    Oct 16, 2017 at 5:09
  • 1
    I'm positive. Everything runs smoothly until I turn off editing mode and save my new field
    – racheldeep
    Oct 16, 2017 at 14:02
  • OK, so it wasn't working on QGIS 2.18 but it worked on QGIS 2.14!
    – racheldeep
    Oct 16, 2017 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.