2

I have been working on a project in ArcGIS 10.5 and found out today (after sending the data) that the main two people that are going to make use of my work are only using ArcGIS 10.3.1 (most of the organisation has already updated to 10.5).

I do not have access to 10.3.1 (I am remote contractor) and while the users can update to 10.5, they can't do it at short notice and yet they need to test and use the data and tools I have sent.

I have used Save a Copy to back-wards save the MXD from 10.5 to 10.3, and they can now successfully open the MXD, but the one ArcToolbox tool they needed in the toolbox I sent was not visible (yet visible and usable in my ArcMap from the same folder).

I figured maybe the toolbox had also re-saved as 10.5, so I did a Save a Copy on the toolbox, back to 10.1/10.2 (the next version back in the selector) - but now they can only see one tool total in the toolbox!

Previously they could see 10 of 11 tools.

How can I make all the tools visible/available in ArcGIS 10.3 if I only have access to ArcGIS 10.5?


Another angle may be that it's not a version issue but rather something else that may be preventing their ArcMap from seeing the script tool.

  • If it is a Python script tool then converting it to a Python Toolbox tool may be an option. – PolyGeo Oct 18 '17 at 21:20
  • @PolyGeo I had considered that, however it's not my toolbox (I didn't create it) and I am not in a position to debug it to get it to work. Plus not all the tools are python. – Midavalo Oct 18 '17 at 21:21
  • I think that I'm currently being stymied by this at gis.stackexchange.com/questions/260460/… :-( – PolyGeo Nov 2 '17 at 23:24
2

It may prove to be difficult to make all the tools visible/available due to Esri documentation Saving toolboxes to earlier versions Unless as PolyGeo mentioned, if it is a Python script.

The internal format of toolboxes can change from release to release. In all cases, newer releases (such as release 10.2.1) can read older version toolboxes (such as 10.0) and execute their tools. However, the opposite is not true—ArcGIS 10.0 cannot read toolboxes created in release 10.2.1. If you are working in an environment where your colleagues or clients have older versions of ArcGIS, you can save toolboxes to an older version and deliver that toolbox.

To save a toolbox to an earlier version, right-click the toolbox and click Save As, then choose the version.

Caution: When you save a toolbox (and its tools) to an earlier version, capabilities that are only available in the newer version are removed. You must examine and test your converted tools on the earlier version.

  • The one tool that was missing was a python script, and there was nothing in the tool parameters that haven't been around for some time (as far as I know) - one field for a GDB path, and the other a check-box. I believe the toolbox was originally developed in 10.3 so should have worked anyway – Midavalo Oct 18 '17 at 21:23
2

I'm not sure I actually know the cause of the problem, but I have solved it (it now works for the users).

The script tool we were trying to use was imported into the toolbox - it didn't have a separate .py file. I exported the script to a separate file and now it works. No other changes (so still the same toolbox I was using in 10.5).

The really odd thing is that when I saved the toolbox to 10.2 or 10.3 the one tool that still remained available was also an imported python script, so I'm not fully sure on the reason why this has worked.

  • Sounds like you have fixed it. In the past, script tools I had created would not port backwards and I ended up having to create an empty 10.3 toolbox and then rebuild the interface for the script tool. A real pain especially if I had sunk time and effort updating the metadata to give it a useful user experience. Just glad your solution worked. – Hornbydd Oct 19 '17 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.