0

I have managed to display Sentinel-1 IW images in Google Earth Engine following this example but when I change the instrumentMode to EW nothing shows in the map canvas and it says "No bands to visualise". I have tried changing dates etc but I get nothing. I guess I'm doing something wrong, but I have no clue what. Any ideas?

// Load the Sentinel-1 ImageCollection.
var sentinel1 = ee.ImageCollection('COPERNICUS/S1_GRD');

// Filter by metadata properties.
var vh = sentinel1
  // Filter to get images with VV and VH dual polarization.
  .filter(ee.Filter.listContains('transmitterReceiverPolarisation', 'VV'))
  .filter(ee.Filter.listContains('transmitterReceiverPolarisation', 'VH'))
  // Filter to get images collected in interferometric wide swath mode.
  .filter(ee.Filter.eq('instrumentMode', 'EW'));

// Filter to get images from different look angles.
var vhAscending = vh.filter(ee.Filter.eq('orbitProperties_pass', 'ASCENDING'));
var vhDescending = vh.filter(ee.Filter.eq('orbitProperties_pass', 'DESCENDING'));
var vhDesc2017 = vhDescending.filterDate(ee.Date('2017-02-10'), ee.Date('2017-02-16'));
var vhAsc2017 = vhAscending.filterDate(ee.Date('2017-02-10'), ee.Date('2017-02-16'));


// Create a composite from means at different polarizations and look angles.
var composite = ee.Image.cat([
  vhAsc2017.select('VH').mean(),
  ee.ImageCollection(vhAscending.select('VV').merge(vhDescending.select('VV'))).mean(),
  vhDesc2017.select('VH').mean()
]).focal_median();

// Display as a composite of polarization and backscattering characteristics.
Map.addLayer(composite, {min: [-18, -18, -18], max: [-30, -30, -30]}, 'composite');
0

I don't know much about radar, but your script is working, or at least shows something, the problem is that when you filtered the collection you discarded images that where in the area you are looking at. Add this at the end of your script:

print("size of vhDesc2017:", vhDesc2017.size(),
      "size of vhAsc2017:", vhAsc2017.size())

Map.setCenter(-24.08, 36.40, 6)
  • Thanks! Now I realised the problem! For some reason the images over Sweden (where I wanted to be didn't have any "VH" polarisation, only "HV", so in the beginning of the script where there was a filter to inly show VV or VH my area disappeared. – oskarlin Oct 19 '17 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.