2

I am performing several viewshed analyses. As I wanted to observe how the viewshed changes when setting a different value for OffsetA I noticed something strange was going on with the cell count.

Firstly, I performed the analysis without an offset value. These were the results:

Viewshed analysis without Offset value

The attribute table states that the cell count is 208141. Then I performed another analysis with an OffsetA of 2m, and I got these results:

Viewshed analysis with offset 2m

Obviously, the viewshed is larger (which I expected it to be), but the cell count as mentioned in the attribute table is lower (113111).

Since I set invisible cells to be returned as NoData, I suspected it might had something to do with that. Therefore I performed the analysis again, but without selecting the option for invisible cells to be displayed as NoData.

This did not change anything and the results were exactly the same.

Am I doing something wrong or am I overlooking something? I am using ArcMap 10.3.

  • Are you working within a file geodatabase, when preforming this analysis? – whyzar Oct 19 '17 at 14:13
  • Yes, I am. Could that be causing the problem? – MvdH Oct 19 '17 at 14:21
  • It is possible, typically I would say no. Try using it outside of the geodatabase environment, to troubleshoot. – whyzar Oct 19 '17 at 14:26
  • I tried running it outside the geodatabase, but no success. I think I might have found a solution though. Initially, I used the Visibility tool with the frequency setting to calculate the viewshed, however, when I use the regular Viewshed tool the count value for the 2m viewshed has 7 digits instead of 6. – MvdH Oct 24 '17 at 9:38
  • 1
    On further investigation I found that a default attribute table is only displaying 6 digits. I have changed this around by right-clicking the field properties in the attribute table and specifying with the number format option, that I wanted more digits to be displayed. This seemed to have been the problem all along! Thanks for taking the time to look for a solution! – MvdH Oct 24 '17 at 9:55
2

I have found the solution to my problem. I never knew that a default ArcMap attribute table only stores numbers up to 6 digits. However, you can specify the amount of digits you want to display by formatting the numeric fields of the attribute table (see also here). When I specified the number of significant digits to 8 and applied the changes, the attribute table updated and a larger count value was displayed for the 2m viewshed (7 digits instead of 6).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.