0

We have SDE Running on SQL Server 2008. I have one user that receives this error once in a while, and not sure why he is the only one receiving it. I have not seen this error before. I checked permissions on the table it referenced (sdm_Equipment) and he has all the necessary permissions.

We have 4 people editing the database concurrently. We are all using ArcMap 10.3.1, and ArcGIS Server 10.3. The Error as seen below in the screen shot is:

Unable to save edits. Underlying DBMS Error Cannot find the object "##SDE_Session3738_15 because it does not exist or you do not have permissions.][ CrescentLinkClarity.DBO.sdm_equipment] The version has been redefined to reference a new database state. [dbo.Default]

What would be causing this error? As I said above I checked the users permissions on sdm_equipment.

error message

  • 1
    Please include error messages as text in the body of a question, and be sure that your Question contains a question. If you have an error message that refers to concurrent access, your question should at least mention how many users are editing concurrently. All questions should always specify the exact GIS software in use. – Vince Oct 20 '17 at 12:30
  • 1
    most likely a user does not have permission to save the edits desktop.arcgis.com/en/arcmap/10.3/manage-data/… – Mapperz Oct 20 '17 at 13:22
  • @Mapperz I thought that at first too. I checked his permissions through ArcCatalog and also double checked with SQL Managment Studio. I'm flummoxed. He is the only one getting this error and he's gotten it a few times. i.imgur.com/4aKypih.png – GravitaZ Oct 20 '17 at 14:37
  • 2
    Did the editor have their edit session open a log time? I've seen users get something similar when they leave an edit session idle for several hours, esp. if others are rec and posting versions. – Dowlers Oct 26 '17 at 19:56
  • @Dowlers I am pretty sure that is what happened! It has been working fine since then. How do I mark your response as an answer? – GravitaZ Oct 31 '17 at 12:47
1

Did the editor have their edit session open a log time? I've seen users get something similar when they leave an edit session idle for several hours, especially if others are rec and posting versions.

Sometimes hitting the refresh button on the versioning toolbar helps but usually the editor has to close ArcMap and reopen it. If they havn't saved their edits then the unsaved edits will be lost.

0
  1. ArcGIS 10.3x supports SQL server 2008 sp3
  2. create a new version and test editing with in this new version.
  3. If you create SDE with ArcSDE version 9x, Stop the SDE service and try to connect with Direct connection or create an enterprise geodatabase with ArcGIS 10.3
  4. manage the users with new versions and Use post/reconsile for conncurrent editing tasks.
0

Looks like it is related to your last edits you made. I undid my last actions, which fixed the issue. Luckily I only had to undo 4 actions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.