4

I have two layers, one in ESPG:4616 (JGD2000) and one in ESPG:30165 (Tokyo, Japan Plane Rectangular CS V). In QGIS, layer are not matching as you can see below.

enter image description here

I tried everything in QGIS, modifying the project projection, with and without "on the fly", recording the layers in another coordinate system, etc. At this point, I through that the problem came from the data.

However, when I open both the layers in ArcGIS, the software do an automatic transformation (one projection into one another) and layers are matching as you can see below.

enter image description here

At this point I am lost, I even tried to record both the layers in a brand new projection in ArcGIS, still layers are not matching in QGIS.

Here is a link with a small sample of both layers

Dropbox file

UPDATE:

ArcGIS also has a problem, when I add a basemap, we can see that both layers are not overlapping

enter image description here

While using open layer in QGIS, one layer is overlapping the background map.

enter image description here

10
  • Can you confirm that when you go into the layer properties, that they both are using the appropriate CRS? i.e. that when importing the layers, another has accidentally been selected
    – Liam G
    Oct 25 '17 at 8:10
  • 2
    It seems that the building layer is correct, but the roads layer is really in Tokyo datum, EPSG:4301 instead of EPSG:4612.
    – AndreJ
    Oct 25 '17 at 8:14
  • I did several tries with ESPG:4616, ESPG:30165 and with WGS84. The only time data are overlapping is in ARCGIS with two different CRS, But yet it does not matches the basemap.
    – ePoQ
    Oct 25 '17 at 8:18
  • 1
    I echo @AndreJ 's comment. Usually Tokyo and JGD2000 has ~400m shift. Changing CRS of roads to EPSG:4301 by Define current projection tool has fixed it in my QGIS 2.18.13 environment.
    – Kazuhito
    Oct 25 '17 at 12:50
  • 1
    Note: In ArcGIS Desktop, in ArcMap, geographic/datum transformations are not applied automatically. They are in ArcGIS Pro.
    – mkennedy
    Oct 25 '17 at 15:41
5

It seems you have wrongly overwritten the Coordinate Reference System (CRS) file of one or both of the layers. This information is stored in the .prj file.

I have no idea how Arcgis handles this, but Qgis uses them to define the CRS of a layer, so if there is a .prj file, QGIS will use it.

You can change the CRS for each layer in the layers panel, but if you want to ammend or restore a worng CRS info in the .prj file, then you have to do what @Kazuhito said in the comments: Vector Data management Tools Define current projection as in the pictures below.

enter image description here

enter image description here

0
1

Update for those reading this post later. I indeed did the mistake of wrongly write the wrong projection within the .prj file of my road layer and the answers provided above resolved my problem.

Yet, as explained here Basemap / shapefile not overlapping the basemap layer within ArcGIS is enable to overlap with some specific projections. And, as a matter of fact, my road layer didn't had any projection file encoded but the automatic transformation process within ArcGIS can set the projection of a layer based on another layer. By doing that, I generated the gap within the above screenshot myself by recording for the first time my layer with no projection while the non-overlapping basemap was open in background.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.