2

The question of how to get rid of the ActiveX warning on every toolbox tool has been the subject of:

and an ArcGIS Idea over the years, but the solutions do not seem to transfer well to newer versions of ArcMap and Windows, specifically in my case Windows 10 Pro.

Pursuant to all of these answers, I've set registry keys 1200, 1201, 1400, and 1406 to 0 in every Zone (and rebooted) with no success. But -- for example -- Windows 10 Pro has no HKEY_CURRENT_USER in the registry; I'm just guessing that HKEY_LOCAL_MACHINE is where the work should be done. And who knows what other harm I've caused by doing so, since I've been following the procedure on the level of superstitious ritual, without any understanding of what I'm changing.

Can anyone update the advice?

  • The settings on this page do not help: gmtsupport.wordpress.com/tag/… – J Kelly Oct 25 '17 at 14:31
  • I followed the DWORD resolution from this article, gis.stackexchange.com/questions/237958/… In addition I changed the style sheets as per this article, community.esri.com/thread/… – Chewp Dec 5 '17 at 14:36
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – aldo_tapia Dec 5 '17 at 18:10
  • @Chewp that stackexchange article is one I linked in the question. I will explore the stylesheet advice; thanks. – J Kelly Dec 5 '17 at 22:12
  • All versions of windows have HKEY_CURRENT_USER (HKCU). Server, Hyper-V Server, Windows, they all will have it. It is your currently loaded registry have for your user profile. – Mgamerz Dec 13 '17 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.