3

I am running QGIS 2.18 on a mac and trying to use the Contours plugin. I've never had problems with it before but then I updated QGIS using Kyngchaos. Now Contours crashes QGIS when I choice "Filled Contours" or "Both". It works fine for generating just contour lines. When it crashes, it doesn't throw up an error window; the whole program just quits.

I tried stepping back to an older version of QGIS but that not only didn't solve the problem, it also created a host of other issues. I've also uninstalled and reinstalled the plugin.

How can I get Contours plugin fully functional again?

  • 1
    not sur it's help but according to github.com/ccrook/QGIS-Contour-Plugin/issues/18 can you try to install python-matplotlib-qt4 ? – Hugo Roussaffa - GeoDatup Oct 27 '17 at 19:58
  • I'm over my head here. Is python-matplotlib-qt4 a tool within matplotlib? I have matplotlib installed and QGIS finds it fine through the python console. – Becca Oct 27 '17 at 20:55
  • Don't know much about matpotlib, and it could not resolve your issue. The contours are written to a memory (scratch) layer. If the MemoryLayerSaver plugin is installed these are saved with the QGIS project. Otherwise they can be saved to another persistant format. Did you installed MemoryLayerSaver ? – Hugo Roussaffa - GeoDatup Oct 28 '17 at 6:56
  • did you try with a sample of your data ? – Hugo Roussaffa - GeoDatup Oct 28 '17 at 7:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.