0

When opening Qgis I get this in the python warning and the following under processing. Any help would be great.

2017-10-27T20:45:03 2 Problem with OTB installation: installed OTB version (5.2.1) is not supported 2017-10-27T20:45:03 2 Problem with SAGA installation: unsupported SAGA version found.

2017-10-27T20:44:52 1 warning:/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pkgutil.py:186: ImportWarning: Not importing directory '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/mpl_toolkits': missing init.py file, filename, etc = imp.find_module(subname, path)

        traceback:  File "<string>", line 1, in <module>
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 333, in startPlugin
            plugins[packageName] = package.classFactory(iface)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/MetaSearch/__init__.py", line 29, in classFactory
            from MetaSearch.plugin import MetaSearchPlugin
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/MetaSearch/plugin.py", line 33, in <module>
            from MetaSearch.dialogs.maindialog import MetaSearchDialog
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/MetaSearch/dialogs/maindialog.py", line 43, in <module>
            from owslib.csw import CatalogueServiceWeb
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/owslib/csw.py", line 27, in <module>
            from owslib.util import OrderedDict
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/owslib/util.py", line 15, in <module>
            import pytz
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/pytz/__init__.py", line 29, in <module>
            from pkg_resources import resource_stream
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2813, in <module>
            add_activation_listener(lambda dist: dist.activate())
          File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 686, in subscribe
            callback(dist)
          File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2813, in <lambda>
            add_activation_listener(lambda dist: dist.activate())
          File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2346, in activate
            list(map(declare_namespace, self._get_metadata('namespace_packages.txt')))
          File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 1942, in declare_namespace
            _handle_ns(packageName, path_item)
          File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 1899, in _handle_ns
            loader = importer.find_module(packageName)

2017-10-27T20:44:53 1 warning:/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py:81: DeprecationWarning: Converters and adapters are deprecated. Please use only supported SQLite types. Any type mapping should happen in layer above this module. register_adapter(datetime.date, adapt_date)

        traceback:  File "<string>", line 1, in <module>
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 298, in loadPlugin
            __import__(packageName)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/__init__.py", line 29, in <module>
            from processing.tools.general import *              # NOQA
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/general.py", line 31, in <module>
            from processing.core.Processing import Processing
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/Processing.py", line 42, in <module>
            from processing.script.ScriptUtils import ScriptUtils
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptUtils.py", line 30, in <module>
            from processing.script.ScriptAlgorithm import ScriptAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptAlgorithm.py", line 33, in <module>
            from processing.core.GeoAlgorithm import GeoAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/GeoAlgorithm.py", line 41, in <module>
            from processing.core.parameters import ParameterRaster, ParameterVector, ParameterMultipleInput, ParameterTable, Parameter
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/parameters.py", line 32, in <module>
            from processing.tools.vector import resolveFieldIndex
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/vector.py", line 47, in <module>
            from processing.tools import dataobjects, spatialite, postgis
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/spatialite.py", line 29, in <module>
            from pyspatialite import dbapi2 as sqlite
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py", line 86, in <module>
            register_adapters_and_converters()

2017-10-27T20:44:53 1 warning:/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py:82: DeprecationWarning: Converters and adapters are deprecated. Please use only supported SQLite types. Any type mapping should happen in layer above this module. register_adapter(datetime.datetime, adapt_datetime)

        traceback:  File "<string>", line 1, in <module>
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 298, in loadPlugin
            __import__(packageName)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/__init__.py", line 29, in <module>
            from processing.tools.general import *              # NOQA
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/general.py", line 31, in <module>
            from processing.core.Processing import Processing
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/Processing.py", line 42, in <module>
            from processing.script.ScriptUtils import ScriptUtils
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptUtils.py", line 30, in <module>
            from processing.script.ScriptAlgorithm import ScriptAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptAlgorithm.py", line 33, in <module>
            from processing.core.GeoAlgorithm import GeoAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/GeoAlgorithm.py", line 41, in <module>
            from processing.core.parameters import ParameterRaster, ParameterVector, ParameterMultipleInput, ParameterTable, Parameter
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/parameters.py", line 32, in <module>
            from processing.tools.vector import resolveFieldIndex
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/vector.py", line 47, in <module>
            from processing.tools import dataobjects, spatialite, postgis
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/spatialite.py", line 29, in <module>
            from pyspatialite import dbapi2 as sqlite
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py", line 86, in <module>
            register_adapters_and_converters()

2017-10-27T20:44:53 1 warning:/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py:83: DeprecationWarning: Converters and adapters are deprecated. Please use only supported SQLite types. Any type mapping should happen in layer above this module. register_converter("date", convert_date)

        traceback:  File "<string>", line 1, in <module>
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 298, in loadPlugin
            __import__(packageName)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/__init__.py", line 29, in <module>
            from processing.tools.general import *              # NOQA
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/general.py", line 31, in <module>
            from processing.core.Processing import Processing
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/Processing.py", line 42, in <module>
            from processing.script.ScriptUtils import ScriptUtils
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptUtils.py", line 30, in <module>
            from processing.script.ScriptAlgorithm import ScriptAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptAlgorithm.py", line 33, in <module>
            from processing.core.GeoAlgorithm import GeoAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/GeoAlgorithm.py", line 41, in <module>
            from processing.core.parameters import ParameterRaster, ParameterVector, ParameterMultipleInput, ParameterTable, Parameter
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/parameters.py", line 32, in <module>
            from processing.tools.vector import resolveFieldIndex
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/vector.py", line 47, in <module>
            from processing.tools import dataobjects, spatialite, postgis
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/spatialite.py", line 29, in <module>
            from pyspatialite import dbapi2 as sqlite
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py", line 86, in <module>
            register_adapters_and_converters()

2017-10-27T20:44:53 1 warning:/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py:84: DeprecationWarning: Converters and adapters are deprecated. Please use only supported SQLite types. Any type mapping should happen in layer above this module. register_converter("timestamp", convert_timestamp)

        traceback:  File "<string>", line 1, in <module>
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 298, in loadPlugin
            __import__(packageName)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/__init__.py", line 29, in <module>
            from processing.tools.general import *              # NOQA
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/general.py", line 31, in <module>
            from processing.core.Processing import Processing
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/Processing.py", line 42, in <module>
            from processing.script.ScriptUtils import ScriptUtils
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptUtils.py", line 30, in <module>
            from processing.script.ScriptAlgorithm import ScriptAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/script/ScriptAlgorithm.py", line 33, in <module>
            from processing.core.GeoAlgorithm import GeoAlgorithm
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/GeoAlgorithm.py", line 41, in <module>
            from processing.core.parameters import ParameterRaster, ParameterVector, ParameterMultipleInput, ParameterTable, Parameter
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/parameters.py", line 32, in <module>
            from processing.tools.vector import resolveFieldIndex
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/vector.py", line 47, in <module>
            from processing.tools import dataobjects, spatialite, postgis
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/spatialite.py", line 29, in <module>
            from pyspatialite import dbapi2 as sqlite
          File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 607, in _import
            mod = _builtin_import(name, globals, locals, fromlist, level)
          File "/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py", line 86, in <module>
            register_adapters_and_converters()
  • Homebrew or kingchaos version? It’s unclear the information about installation – aldo_tapia Oct 28 '17 at 2:32
  • I'm using the kingchaos version – James Oct 28 '17 at 12:13
1

1) Try first to deactivate OTB and SAGA providers on the processing settings.

2) Install the Kyng Chaos Python module Matplotlib. It gets installed into the /Library/Python/2.7/site-packages/matplotlib-override directory and a /Library/Python/2.7/site-packages/matplotlib-override.pth file). If you use the Kyng Chaos version, you absolutely need it.

enter image description here

In the Python shell or the Python console of QGIS

import mpl_toolkits
mpl_toolkits.__file__
'/Library/Python/2.7/site-packages/matplotlib-override/mpl_toolkits/__init__.pyc

and not /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/mpl_toolkits'

3) warning:/Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py:83: DeprecationWarning

It is only a Warning: deprecation warning. If you really want to ignore them (lines 81 to 84), you can use the correction proposed in bugs.python.org

Replace in the file /Library/Frameworks/SQLite3.framework/Versions/C/Python/2.7/pyspatialite/dbapi2.py, lines 81 to 84

def register_adapters_and_converters():
    .....
    register_adapter(datetime.date, adapt_date)
    register_adapter(datetime.datetime, adapt_datetime)
    register_converter("date", convert_date)
register_adapters_and_converters()

by

import warnings
.....
def register_adapters_and_converters():
    .....
    with warnings.catch_warnings():
       warnings.simplefilter('ignore', DeprecationWarning)
       register_adapter(datetime.date, adapt_date)
       register_adapter(datetime.datetime, adapt_datetime)
       register_converter("date", convert_date)
register_adapters_and_converters()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.