I'd like to edit, create new and delete attribute fields using ArcGIS Pro. I open attribute table using short cut Ctrl + M. When I click Field View Field view

So I try to add new, or any manipulation. But the most important question. How to save edits? ESRI tell me to click save. But where's "save" button?

  • Which of editing, creating new and deleting attribute fields using ArcGIS Pro do you wish to ask about in this particular question. I have had no trouble doing any of those operations so once we know precisely what you have tried and where you are stuck your question should become very answerable. – PolyGeo Oct 30 '17 at 10:11
  • I've unchecked Read Only tick – can't save. But Field was optional, not geometry or OID. I tried something more with different data – I can create new and calculate. Delete input after that. So it seems all is working. All I need is just to explore more. – Nežinomas Asmuo Oct 30 '17 at 10:30

So I found save button in the ribbon menu

The answer

But save command is currently disabled due to my improper (I assume) changes. Description tells:

Save is enabled when there are valid edits to the fields, but disabled if the current project contains unsaved feature edits.

I tried many edits but all came to disabled save button.

So I have finally solved all my troubles. You can't save fields while editing. Just save editing and after that you can change fields options!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.