1

I am trying to execute the TopologicalBreachBurn script in Whitebox GAT. This is my first time using this software so am generally unfamiliar with how it operates. I imported a DEM as an ASCII .txt to convert it to the required .dep format needed for the script. Then I selected a streams vector .shp. When I hit run, it gives me the error: "an error occurred during operations. See log for details."

When I open the log there is nothing there, so I am not able to ascertain what the error actually is. Anyone run into this issue or know what may be happening?

  • One possibility is your streams shapefile contains multipart object(s). In my test case (which reproduced error) the log says java.lang.ArrayIndexOutOfBoundsException: 80 in the Error in Topological Breach-Burn (Stream Burning) section. If it is the case please convert your shapefile to single parts and try to run the tool again. – Kazuhito Nov 4 '17 at 8:52
  • @Kazuhito Thank you for this suggestion, I converted my file to singlepart features and am still receiving the error. Perhaps anyone else has a solution? – Kerry Nov 7 '17 at 14:34
  • Are they the same coordinate system? – Hornbydd Nov 23 '17 at 12:34
  • @WhiteBoxDev Might have an idea. – traggatmot Jul 26 '18 at 18:38
1

I ran into the same problem and was able to get the tool to run, though I'm not exactly sure why my steps worked. In my case I did have error messages in the log.

The first error message was "java.lang.NullPointerException" which wasn't much help. But after reading the paper referenced in the help I realized that the way it worked might mean that the stream network needed to be split at all intersections, which mine was not. I used GRASS' v.clean to break the lines at intersections and exported a shapefile.

This time I got the error message "java.lang.ArrayIndexOutOfBoundsException: Negative array index [-32769] too large for array size 952" I guessed that something was not right with my shapefile(since it had 952 features) so I used QGIS to convert it to a geojson file and then back into a shapefile.

Third time was a charm and it ran successfully. I'd try using a tool like v.clean to correct topology errors and/or try converting out of the shapefile format and back in to see if either of those steps help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.