2

can't install qgis as per qgis download page.

at command line:

sudo apt-get install qgis python-qgis qgis-plugin-grass

getting unmet dependencies:

The following packages have unmet dependencies:
 python-qgis : Depends: python-qgis-common (= 1:2.18.14+13jessie) but 1:2.18.11+24xenial is to be installed
               Depends: libqgispython2.18.14 but it is not going to be installed
               Depends: libgdal1h (>= 1.8.0) but it is not installable
               Depends: libgeos-c1 (>= 3.4.2) but it is not installable
               Depends: libproj0 (>= 4.8.0) but it is not installable
               Depends: libqgis-analysis2.18.14 but it is not going to be installed
               Depends: libqgis-core2.18.14 but it is not going to be installed
               Depends: libqgis-gui2.18.14 but it is not going to be installed
               Depends: libqgis-networkanalysis2.18.14 but it is not going to be installed
               Depends: libqgis-server2.18.14 but it is not going to be installed
               Depends: libqwt6 but it is not installable
               Depends: libspatialindex3 (>= 1.8.1) but it is not installable
               Depends: libspatialite5 (>= 2.4.0) but it is not installable
               Depends: sip-api-11.1 but it is not installable
 qgis : Depends: libgdal1h (>= 1.9.0) but it is not installable
        Depends: libgeos-c1 (>= 3.4.2) but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        Depends: libproj0 (>= 4.8.0) but it is not installable
        Depends: libqgis-analysis2.18.14 but it is not going to be installed
        Depends: libqgis-app2.18.14 but it is not going to be installed
        Depends: libqgis-core2.18.14 but it is not going to be installed
        Depends: libqgis-gui2.18.14 but it is not going to be installed
        Depends: libqgis-networkanalysis2.18.14 but it is not going to be installed
        Depends: libqwt6 but it is not installable
        Depends: libspatialindex3 (>= 1.8.1) but it is not installable
        Depends: libspatialite5 (>= 2.4.0) but it is not installable
        Depends: qgis-providers (= 1:2.18.14+13jessie) but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.18.14+13jessie) but it is not going to be installed
                     Depends: libgdal1h (>= 1.8.0) but it is not installable
                     Depends: libgeos-c1 (>= 3.4.2) but it is not installable
                     Depends: libproj0 (>= 4.8.0) but it is not installable
                     Depends: libqgis-analysis2.18.14 but it is not going to be installed
                     Depends: libqgis-app2.18.14 but it is not going to be installed
                     Depends: libqgis-core2.18.14 but it is not going to be installed
                     Depends: libqgis-gui2.18.14 but it is not going to be installed
                     Depends: libqgisgrass6-2.18.14 but it is not going to be installed
                     Depends: libqwt6 but it is not installable
                     Depends: libspatialindex3 (>= 1.8.1) but it is not installable
                     Depends: libspatialite5 (>= 2.4.0) but it is not installable
                     Depends: grass644 but it is not installable
E: Unable to correct problems, you have held broken packages.

deb http://qgis.org/debian jessie main
deb-src http://qgis.org/debian jessie main

deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu jessie main

any ideas out there

  • I haven't been able to get this to work either... – DPSSpatial Nov 3 '17 at 19:23
  • it's maddening. changed [link] (ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/dists/… to version xenial. still no go. – geomajor56 Nov 3 '17 at 19:32
  • It's still a non-LTS version of Ubuntu, and QGIS seems to be stable on LTS, so I'm not sure what the deal is. Maybe someone on the Dev team can verify if it does work?? – DPSSpatial Nov 3 '17 at 19:36
  • 1
    Ubuntugis only supports Ubuntu xenial, trusty and precise, see launchpad.net/~ubuntugis/+archive/ubuntu/ubuntugis-unstable. So no chance for Ubuntu 17.10. – AndreJ Nov 4 '17 at 6:31
  • 1
    You can install a recent version from the standard repos, no need for ubuntugis which only supports LTS Ubuntu versions. If you want the latest and greatest, install MiniConda. Type conda create -n qgis -c conda-forge qgis then type source activate qgis then type qgis – user2856 Nov 5 '17 at 6:48
3

The version name for Ubuntu 17.10 is artful therefore your repository statements must read

deb http://qgis.org/debian artful main 
deb-src http://qgis.org/debian artful main

This is clearly documented on the download page. jessie is a debian release, not a ubuntu release.

  • 1
    ubuntugis is optional for Ubuntu later than 16.04 and may occasionally cause problems with different package versions. Unless you require something that is specifically in ubuntugis and not in your distro's packages then it can be left out. – enzedrailmaps Nov 3 '17 at 23:04
  • 2
    Ubuntugis is designed to supply new packages to Ubuntu LTS versions. Current Ubuntu versions have most recent versions of GIS software in the main repository, so no need for Ubuntugis for them. – AndreJ Nov 4 '17 at 17:49
1

Remove qgis.org/debian and ubuntugis from your sources.

Update

apt update

Install QGIS (2.14 is in the 17.10 repos)

apt install qgis

If you want QGIS 2.18 (3.0 when it's released), install it via Anaconda.

Install miniconda:

wget https://repo.continuum.io/miniconda/Miniconda3-latest-Linux-x86_64.sh
bash Miniconda3-latest-Linux-x86_64.sh

Install QGIS

conda create -n qgis qgis
source activate qgis
qgis

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.