1

I am having problems with the Editor function "construct points" in ArcGIS. If I select the line where I want to construct the points, the direction of the points is not correct. The orientation arrows are not going in only one direction but starting from both sides of the line (see attached picture). Has anyone experienced a similar problem?

constructpoints

2

The reason you are seeing this is because of malformed geometries. Visually you see a continuous line but in fact you have a multi-part polyline where the end node is in the middle of the line.

Traditionally you draw a polyline starting from one end and click along then stop. This line would have been created such that it started, went to the middle, finished that PART, then went from some other location to the middle, rather than just continuing from the end of the first part.

You can prove this is multipart simply by going into edit mode, selecting the line, then clicking on the edit vertices button on the editor toolbar.

How you resolve this is to edit the polyline, ArcMap usually fixes such topological inconsistencies, or try the planarize tool on the advance editing toolbar.

  • Thank you for your answer. you're right, it is multipart. instead of union the different line segments i tried the merge function and with that it works now. – Mirjam Nov 10 '17 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.