2

I'm importing data from a ArcGIS .gdb to a POSTGIS DB using FME Desktop 2016. For this I need first to rename single attribute names using the AttributeRenamer transformer. My problem is that, reader attributes with width 254 (data type "text") are automatically transformed to writer width 200 (type "varchar"). Why does FME cut the width of the attributes, is it a bug?

However, this issue only appears when I use an AttribruteRenamer. I also tried the BulkAttributeRenamer, which retrieves the same. Any ideas?

  • I there any solution to the change to default datatype when using BulkAttributeRenamer? Except doing it manually. – Anton Feb 28 at 16:30
0

I think you're probably using the writer with an Automatic schema:

enter image description here

So anything that connects to the writer gets an attribute. However, unless it came from the original schema, FME doesn't know what data type it should be.

In my screenshot (above) Name got renamed to parkname (and ID to parkid). Because of the automatic mode, parkname gets a definition on the writer; but because there is no such attribute on the source schema FME doesn't know what data type it should be. It defaults to varchar200.

Ideally we (I work for Safe Software) would improve FME's behaviour. It certainly ought to notice that parkname is just a rename of a source attribute. But in the meantime you could turn off the automatic attribute definitions; either turn it to manual completely or turn it to manual before running the workspace and edit the field widths manually at that point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.