1

Tested with QGIS 2.8, 2.14 and 2.18 on same desktop Client.

QGIS Proxy-settings on network-settings are set to DefaultProxy. OpenLayers plugin GoogleMaps works properly. Uses SystemProxy.

OpenLayers plugin OpenStreetMap allways tries to bypass the proxy and send requests directly into the internet. This is denied by firewall. WWW-access only allowed via proxy.

Tried to do diagnostics with Fiddler4. I see the requests for GoogleMaps passing Fiddler forwarded to SystemProxy. Everything fine. QGIS-OSM requests do not appear in Fiddler. QGIS-OSM requests appear in Firewall log as denied requests.

So while QGIS-GoogleMaps works properly and QGIS-OSM does not use DefaultProxy, the question is: Is there any other setting in QGIS-Software where I can force OSM Plugin to direct the requests to Proxy?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.