I tried to install QGIS 3 (2.99) on LUbuntu 17.10, but run into errors. I tried to follow/adapt the instructions on QGIS website.

If I add artful entries to /etc/apt/sources.list:

deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu artful main
deb http://qgis.org/ubuntugis-nightly artful main

I get 404 Not Found errors with sudo apt-get update:

Err:6 http://qgis.org/ubuntugis-nightly artful Release                         
  404  Not Found [IP: 104.27.139.220 80]
...
Err:10 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu artful Release
  404  Not Found

If I use xenial entries in /etc/apt/sources.list instead:

deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu xenial main
deb http://qgis.org/ubuntugis-nightly xenial main

Then

$ sudo apt-get install qgis

I get errors:

Reading package lists... Done
...
 The following packages have unmet dependencies:
 qgis : Depends: libgsl2 but it is not installable
        Depends: libqgis-analysis2.99.0 but it is not going to be installed
        ...
        Depends: qgis-providers (= 1:2.99.0+git20171103+c9ee3ef+24xenial-ubuntugis) but it is not going to be installed
        Recommends: qgis-plugin-grass but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any suggestions on how to install QGIS3 on Ubuntu 17.10?

-- Edit --

By the way, I've also tried to use Debian directly:

deb     http://qgis.org/debian jessie main
deb-src http://qgis.org/debian jessie main

But it also gives an error:

$ sudo apt-get install qgis
Reading package lists... Done
...
Some packages could not be installed. 
...
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qgis : Depends: libgdal1h (>= 1.8.0) but it is not installable
        Depends: libgeos-c1 (>= 3.4.2) but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        ...
        Depends: python-qgis (= 1:2.18.14+13jessie) but it is not going to be installed
        Depends: qgis-providers (= 1:2.18.14+13jessie) but it is not going to be installed
        Recommends: qgis-plugin-grass but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
up vote 7 down vote accepted

This is what worked for me for qgis3 (2.99):

Add following to /etc/apt/sources.list and remove previous qgis entries

deb http://qgis.org/debian-nightly artful main 
deb-src http://qgis.org/debian-nightly artful main

Then, in command-line:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys CAEB3DC3BDF7FB45
sudo apt-get update
sudo apt-get install qgis python-qgis

I had to use debian-nightly and also apt-key to get it work.

Ubuntugis is not provided for higher than xenial and is not needed for Qgis 2.99 unless you have xenial or older. There may be an update to ubuntugis when the next ltr of Ubuntu comes out (18.04)

http://qgis.org/ubuntugis-nightly/dists/

Just use the regular debian repository to install qgis.

  • regular debian repository doesn't work for me either. Please see the edit. – tinlyx Nov 11 '17 at 22:56
  • That's because you have used the codename for a debian edition instead of a Ubuntu edition. The debian repository is for both Debian and Ubuntu, the packages for both are there under the same repository path. – kahukowhai Nov 12 '17 at 23:19
  • 1
    As a sidenote, you MUST use ubuntugis if you want QGIS 2.99 on xenial, see qgis.org/en/site/forusers/alldownloads.html#id16 . And no chance for trusty and precise. – AndreJ Dec 21 '17 at 14:27

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.