2

I'm a (relatively) new Mac QGIS user, and I'm having trouble with my processing toolbox.

Specifically, I'm having an issue with the Orfeo toolbox not activating after downloading the last update (2.18.14). I successfully re-downloaded the Orfeo Toolbox folder from this website: https://www.orfeo-toolbox.org/download/

It downloaded into one of the "users" on my computer, but I moved the file to the Applications section where QGIS downloaded. When I open Processing>>Options I see Orfeo toolbox, and it's checked as being active. See below: enter image description here

I've checked that the applications and command line files are correct from other message boards on this website, so I don't think that should be the issue at this point but let me know if they're not correct.

Under the menu section of the Processing>>Options section, I see the Orfeo toolbox but there aren't any dropdown options like the other menu options that are actually showing up.

enter image description here

Any ideas as to what I've done wrong here?

1

Did you install QGIS from KingChaos source? If so... From KingChaos download page:

QGIS includes its own internal copies of GRASS, Orfeo Toolbox, SAGA and TauDEM.

OTB is already in QGIS installation folder. Check the following path inside Applications/QGIS.app:

enter image description here

After this, use the right paths in Processing options:

enter image description here

Finally, OTB will be able in Processing Toolbox:

enter image description here

  • I did use King Chaos and I see the Orfeo toolbox in the contents of QGIS, and I used the path that is in your second picture, but it's still not showing up in the toolbox. Any other suggestions as to why it wouldn't be showing up? Could it have something to do with the visibility of the menu? – Alyssa Hall Nov 16 '17 at 16:15
  • I would dig into ~/qgis2 folder (hidden folder). A solution could be to delete all the contents except ~/qgis2/python folder (to preserve plugins) and relaunch QGIS. If this doesn't solve the problem, reinstall QGIS – aldo_tapia Nov 16 '17 at 17:37
0

I resolved this in windows by creating a filepath without spaces or special characters by placing folder in C: and renaming folder to 'OTB' then adjusting the OTB applications folder and command lines tool folder. Reminiscent of the install for LAStools

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.