0

I'm trying to do an IDW interpolation with QGIS tool. But i'm really surprised by results. Interpolation values aren't similar as shape values. I used a power of 0.2 to get a smooth raster. Somebody have an idea ?

>>Here are data<<

enter image description here enter image description here enter image description here

  • 1
    This really doesn't tell us enough to help you. How many values are there more than 540? What is the spatial distribution of values (map would be good)? Have you tried this with other tools to see if the issue is QGIS specific? – Liam G Nov 15 '17 at 9:36
  • Yes, i'll give you some details. I tried SAGA idw and it always crash with 'NoneType' object has no attribute 'crs' See log for more details. I add in my post 2 screen shots to describes values distribution. – Tim C. Nov 15 '17 at 10:00
  • it looks quite normal, most of data points are below 1080, but there are some outlayers. What are you interpolating? why do you want the outlayers in your raster? – Marco Nov 15 '17 at 10:05
  • I'm interpolating vines biomasse. I don't understand why values ​​under 540 aren't represented when there are many. And what do you mean about outlayers? – Tim C. Nov 15 '17 at 13:35
  • By the looks of your sample image, you have plenty of points under 540 represented - can you explain what you mean when you say they aren't represented. Also your IDW legend shows a truncated scale of 539.15 and below. If you are expecting values above this, try recalculating statistics. – MappaGnosis Nov 15 '17 at 14:19
-1

If I understand correctly, The histogram shows correct range of the data. But you have selected cumulative count cut in style manager, that's why by default min 2% and max 2% have been truncated from the range. Choose the min/max option to see the whole range in the legend as well as map. enter image description here

  • I already use min/max – Tim C. Nov 16 '17 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.