12

Every time I select a feature or edit or split a feature the selection, appears to slowly pulse which is a new visual effect in Pro.

The pulse effect takes way too long bordering on annoying which is especially cumbersome when splitting a feature to many parts as every part slowly pulses after the split operation completes.

The whole editing experience feels slower and non-responsive as a result.

Is there a way to turn off ALL such animated effects in ArcGIS Pro?

  • 2
    I too find the Pro UI sluggish, despite it being the latest and greatest and me using a new i5 core machine at work. I've been doing a lot of map making in Pro recently and find jumping around the ribbons and panels very sluggish and not at all as responsive as one would expect for a modern piece of software. But I can't just point the stick at just ESRI, I find the UI of Excel 2013 is is even worse... – Hornbydd Nov 16 '17 at 16:48
  • 1
    but it looks so COOOL – atxgis Nov 16 '17 at 22:29
  • @atxgis - yes for the first 2 minutes. then I want it all gone and to never see it again. Try splitting a large complex polygon to many parts and you will be treated to a very fine, slow and long pulse show indeed... – Jakub Sisak GeoGraphics Nov 17 '17 at 13:36
  • I've not noticed this, but I rarely edit, and am wondering what version(s) of ArcGIS Pro you have noticed it in? – PolyGeo Nov 20 '17 at 1:11
  • I've only been extensively working with 2 and 2.01 but if i remember correctly these type of effects have been there since version 1. – Jakub Sisak GeoGraphics Nov 22 '17 at 18:49
3
+50

In short, I don't believe ArcGIS Pro has made it available through any immediate checkbox that you can turn on or off. It may be a combination of factors that may improve your experience (RAM, graphics etc...) in the meanwhile as the current solution I could recommend. It may or may not help, but something to be aware of to perhaps lessen the current frustration.

Also, as part of my response, I included converted the MP4 of your animated gif that I came across while searching for possible solutions selection hartbeat animation.mp4.

enter image description here

To provide some anecdotal answer and my experience I've searched other outlets and even tested out my own machine while editing, selecting etc... and experienced a similar thing while editing but not selecting on the machine I'm working on, 8gb RAM, with DirectX rendering selected by ArcGIS Pro based on my graphics card.

You may want to look into the Set display options

  • Antialiasing mode
  • Text antialiasing mode
  • Stereoscopic mode
  • Rendering quality
  • Rendering engine
  • Vertical synchronization
  • Hardware antialiasing
  • Local cache

In addition, consider this as well GPU resources

In ArcGIS Pro, the graphics engine limits drawing based on the abilities of your graphics processing unit (GPU). Sometimes, if these limits are exceeded, a scene will draw incompletely. You may also notice degraded drawing performance, such as low frame rates or "stuttering" of the view, when the current view is consuming resources close to the limit. If you exceed the GPU resources, you will see a warning message that states, "GPU resources exceeded. Consider closing some views or modifying layer settings to reduce the amount of data being displayed."

To restore full drawing of the map, or to restore your drawing performance, you can modify the scene to reduce the load on your GPU

Reduce the load on the GPU

You can try the actions listed here to reduce the load on the GPU and restore your drawing performance.

You can lower the Rendering quality setting on the Display Options dialog box.

Lowering this setting reduces the detail of elevation and reduces the resolution of textures in multipatch features to lower the demands on the GPU.

You can reduce the distance visibility limit for one or more layers in your scene. You can do this on the General tab of the Layer Properties dialog box.

Change the Out Beyond parameter to a shorter distance.

If your geometry is dense, even when the distance visibility is limited, you can reduce the density of geometries displayed in your scene.

If your geometries are multipatches or you're using a multipatch as a marker symbol, use tools to simplify the geometries. The 3D Workshop Feature Extraction Tools are beta tools to repair and simplify multipatch geometries.

The Local Government Scenes solution has generalization tools, the LOD2 and LOD3 building tools, for multipatch geometries.

If you're using traditional GIS geometries, such as points, lines, and polygons, use tools in the Generalization toolset to reduce the density of geometry that is present in your features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.