I'm using GRASS GIS Ver 7.2.2. When I enter command mode and type "g.extension r.hypso" I get the message:

Downloading precompiled GRASS Addons ... ERROR: Extension not found

This happens with all of the extensions I've tried to download (attempts over a 3-day period). I re-installed GRASS with no luck.

I am able to query the server's directories and get a list its contents but not successfully add an Addon to GRASS GIS.

  • I just tried and it seems to be back.
    – markusN
    Nov 18, 2017 at 23:30
  • Thanks, but I still have had no luck. I can get a list of addons (g.extension -l) but still getting the message ERROR extension not found when I input g.extension r.basin (for example). I've reinstalled both GRASS GIS and QGIS once again and tried to add the addons using both interfaces. My GRASS_ADDON_BASE has been properly set. Ideas?
    – B. Mullen
    Nov 19, 2017 at 18:39
  • I'm running Windows 10 and GRASS 7.2.2 64-bit version. But when I query "About System" within GRASS it says that my platform is Windows-8-62.9200. I'm suspecting that this has to do with Windows because otherwise wouldn't it'd try and download the COMPILED addon and not the PRE-COMPILED addon? I believe that my computer is using Microsoft Visuals C++ 2015 Redistributable (X64) - 14.023026. This is deeper than I've ever looked but I am getting desperate to add GRASS addons which I've done previously.
    – B. Mullen
    Nov 20, 2017 at 15:04
  • Maybe it's not very helpful, but I have the same problem with Windows 10, GRASS 7.2.2 64-bit, and I have tried on different computers getting the same error message. I have also installed GRASS-7.0.5, but neither worked when installing different addons. I vote that the server is not working properly. Do you know how to install the addon manually once you have download the zip from wingrass.fsv.cvut.cz/grass72/x86_64/addons/grass-7.2.2? Thank you
    – M.Sapena
    Nov 21, 2017 at 12:06
  • That's at least three of us using Windows that can't download GRASS addons, something which I've been able to do in the past. Sounds like a server issue. No, I haven't yet done a manual add, I was waiting for more responses to my posted question.
    – B. Mullen
    Nov 21, 2017 at 13:29

5 Answers 5


It's working already. I was able to install it successfully without change anything. So I guess they solve the problem!

  • The server must be back up and running properly but it apparently had technical difficulties for several days. I was able to add the GRASS Addons this morning simply by using the g.extension command, something that I hadn't been able to do for the past few days. Curious thing: not all of the addons are listed when I open the GRASS Layer Manager and expand the Addons folder. But they are in GRASS nevertheless!
    – B. Mullen
    Nov 22, 2017 at 13:59

The server was indeed apparently experiencing technical difficulties. I was finally able to install GRASS addons today using g.extension, something that I'd been trying to do for several days.


Same problem as you, can't download addons from repository, they seam to exist but can't find them when I try to install. About the platform I think this version (even win 10) is the Windows-8-62.9200 compiled binary, so don't worry it work perfectly, the problem is the server, I guess.

  • 1
    Have also tried to install addons from the following site but I can't even get a list from there: wingrass.fsv.cvut.cz/grass72/x86_64/addons/grass-7.2.2 At least I can get a list of available addons from the official site that g.extension uses by default. Problem must be the server, I was able to add addons until recently.
    – B. Mullen
    Nov 20, 2017 at 22:55

The windows repository seems to be hardcoded to http://wingrass.fsv.cvut.cz/grass74/x86_64/addons/grass-7.4.4/ (in grass 7.4 at least).

The files are actually located at http://wingrass.fsv.cvut.cz/grass74/x86_64/addons/grass-7.4.svn/

C:\>g.extension url="http://wingrass.fsv.cvut.cz/grass74/x86_64/addons/grass-7.4.svn/" 
--verbose extension=v.tin.to.rast
Downloading precompiled GRASS Addons <v.tin.to.rast>...
Downloading source code for <v.tin.to.rast> from
which is identified as 'remote_zip' type of source...
ERROR: Extension <v.tin.to.rast> not found

Bug ticket https://trac.osgeo.org/grass/ticket/3455


The windows precompiled versions of the addons don't appear to be located in the main repository at the moment (now at https://github.com/OSGeo/grass-addons), but at http://wingrass.fsv.cvut.cz. The problem seems to be that the (incorrect) url is hardcoded in grass.

There is a ticket for this: https://trac.osgeo.org/grass/ticket/3455

Python scripts can be installed manually by copying the files as follows (example for v.transects.py):

v.transects.py to %APPDATA%\GRASS7\addons\scripts and link to \bin

v.transects.html to %APPDATA%\GRASS7\addons\docs\html\

image files to %APPDATA%\GRASS7\addons\docs\html\

Update %APPDATA%\GRASS7\addons\modules.xml to match the relevant section from https://grass.osgeo.org/addons/grass7/modules.xml

You might need to update the name of the script in modules.xml to add the py extension (or rename the file).

You can find the addon in the modules table of the layer manager under addons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.