2

I am working on a project where I made domains for my feature classes, and I need to connect the domain to the actual feature class. When I go to the Feature Class properties, the domain field is not showing up. I have attached a screenshot of the issue. I am using ArcMap 10.5. The second screenshot in the image is from the project instructions. enter image description here

  • 3
    Your field is a short integer your domain is a long integer, they don't match so your domain wont show up; because you have no short integer domains in your database the domain box will not appear for your short integer field, there's nothing to put into it. If you were to create your field with a long integer type you will see your domain box and be able to select the amenity_types domain for that field. – Michael Stimson Nov 20 '17 at 2:41
3

As commented by Michael Stimson your field types don't match between your Domain and your Feature Class Field.

In your project instructions it has said to create a Short Integer field, but your domain you have created as a Long Integer (the Default).

enter image description here

You have several options here.

  1. Delete your domain and create it again using the correct Field Type. Note that you will be unable to do this if you have successfully linked your domain to a field elsewhere in your geodatabase.
  2. Delete and recreate the field in your feature class to match the field type in the domain. Note that if you already have data in this field you will lose it.
  3. If neither of these are satisfactory, you could just create a new domain with a new name (using the correct field type of course) and leave the existing domain there. Link your field to that new domain
  • Is there a different way than doing this? desktop.arcgis.com/en/arcmap/10.3/tools/data-management-toolbox/… – Christina Nov 20 '17 at 3:38
  • Yes, in the fields dialog you have in your pictures, select the domain box associated with the field, it will drop down, then select the empty space to unset your fields' domain. If it's being surly there's probably a schema lock.. close ALL Esri products, including python scripts, open just ArcCatalog and try again.. it should be more obliging now. – Michael Stimson Nov 20 '17 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.