1

I have used MMQGIS geocoder multiple times and then saved the output with a CRS of British National Grid (BNG) 27700 with no issue. However, I am currently trying to achieve the same result but get the following error message:

Export to vector file failed. Error: Failed to transform a point while drawing a feature with ID '48'. Writing stopped. (Exception: forward transform of (-2.026525, 0.783758) PROJ.4: +proj=longlat +datum=WGS84 +no_defs +ellps=WGS84 +towgs84=0,0,0 +to +proj=tmerc +lat_0=49 +lon_0=-2 +k=0.9996012717 +x_0=400000 +y_0=-100000 +ellps=airy +towgs84=446.448,-125.157,542.06,0.15,0.247,0.842,-20.489 +units=m +no_defs Error: latitude or longitude exceeded limits)

The error states that the latitude or longitude exceeded limits.

When I open up the attribute table for the MMQGIS output I cannot see any obvious problem. There is no x or y fields but that is normal for MMQGIS because it does not create them.

The project CRS is set to BNG 27700 and the output from MMQGIS is ESPG:4326, WGS 84.

MMQGIS projection

2
  • Maybe you should set the project CRS to EPSG:27700 as well while you are running the geocoder.
    – AndreJ
    Nov 20, 2017 at 11:49
  • Please copy the text of the error message as a code block instead of adding a screen capture.
    – user30184
    Nov 20, 2017 at 11:57

1 Answer 1

4

You have points that are not in the UK.

These will be outside the extents of the projection system and cannot be converted to EPSG:27700.

Zoom to the layer extent and delete all points not in the UK.

3
  • It is true that the point is not inside the valid area of EPSG:27700 but there may be something else that makes the real issue. This succeeds gdaltransform -s_srs epsg:4326 -t_srs epsg:27700 -2.026525 0.783758 397132.247562689 -5440970.51883177 246.321689824574
    – user30184
    Nov 20, 2017 at 12:02
  • You were right, there was one point way out of the BNG extent. However when I have gone it to it and deleted it I still get the same error message. I then zoom to layer and it appears to be remembering the deleted poibt even though it is not there?
    – AWGIS
    Nov 20, 2017 at 12:28
  • 2
    Did you save your edits (turn off digitising)? Nov 20, 2017 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.