0

I'm working with gdal and trying to run gdal2tiles.py. The command gdal2tiles.py -z 4-18 image.tif tile works on my mac, but it does not work when I run in a linux machine.

I found the solution, already, at gdal2tiles.py gives ERROR 6 about EPSG:900913 on fresh Ubuntu 14.04 install.

But, the point is: Why MacOS recognize EPSG 900913 and Ubuntu does not, since the both code are the same?

4
  • 1
    Are you positive that you have same GDAL build on both machines? You fixed gdal2tiles.py on both machines?
    – mkennedy
    Commented Nov 20, 2017 at 23:34
  • I have 1.11.5 for Mac and 1.10.1 for Ubuntu (which is the last version for this OS). But the line self.out_srs.ImportFromEPSG is the same for both. Also, I've tried to copy the gdal2tile.py from Mac to Ubuntu machine. Commented Nov 21, 2017 at 9:57
  • I guess that your Mac has definition for 900913 in the epsg file that may be in the share/proj directory but your Ubuntu does not. And why, it depends on the stuff that the one who made the build has used as ingredients, in this case, the Proj.4 version.
    – user30184
    Commented Nov 21, 2017 at 11:07
  • Proj version for Mac is 4.9.3 and for Linux is 4.8.0. The versions are different but there is no definition for 900913 in both files. Commented Nov 21, 2017 at 13:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.