I've made a few maps in QGIS Composer and set them up initially as 8.5x11 page size. I want to begin with that layout and apply it to 11x17 page size. However when I change this in the Page Layout, only the page dimensions change. The symbol sizes should have changed as well but they look the same as if they were printed on an 8.5x11. The fonts also remain the same size in relation to the composer page. When the page is saved to PDF, Acrobat does not recognize that the page is 11x17 and still shows it as 8.5x11. Am I missing something?

5 Answers 5


For posterity (since I think I have discovered the issue here, or at least had a different one myself): there is a "Page Size" setting in the Layout>Page Setup dialog that does not modify the layout of the composition manager. I suspect that this is what you were talking about cndnflyr, since your description matches what I was doing (ineffectually) to a "T"... this merely modifies the printing properties of the composition.

What you want is the "Page Size" setting in the "Page Properties". In Q2.x, this setting was found at the top of the "Composition" tab; now in Q3.x, that tab has been renamed to "Layout" and the setting has been moved. You can still find the setting by right-clicking anywhere in the main frame of the Composition editor (like on your map) and click "Page Properties" from the resulting context menu here.

  • 6
    THANK YOU for this! I was going a little nutso trying to find out how to quickly generate an A3 layout in Q3. It's crazy that you can't find this setting from anywhere else (as far as I can see).
    – she_weeds
    Apr 10, 2018 at 8:51

If anyone is having this issue in QGIS 3, the settings are hidden (as of QGIS 3.22)...

  • Right-click the page
  • Choose 'Page Properties...'
  • The 'Item Properties' panel now contains your page size settings (it doesn't normally show them)

This is a strange method to get to the page size, as I'm seeing issues even using the menu Layout > Page size on various operating systems to no avail.

Lastly, this answer came from Reddit: https://www.reddit.com/r/QGIS/comments/89w45j/qgis_3_print_composer_paper_sizes/

  • I have the same issue (QGIS 3.4.1) like described from DPSSpatial: after right-click into the layout the size settings will appear in the element properties...strange thing, but if you know it...ok...thanks so far
    – eurojam
    Nov 12, 2018 at 8:38
  • 2
    In 3.4.5 it is called 'Page properties'
    – LMB
    Mar 20, 2019 at 20:38

In QGIS 3.2.2, in the Layout Manager, you can now find that setting in Layout-->Layout Properties-->and under the Layout tab click the Resize layout button.

enter image description here

It will resize the layout to the size of your map, which is in the Item Properties menu. Right click in map-->Page Properties-->in the Item Properties menu you'll see the Width and Height enter image description here


After you resize the basic page you also resize the map object and any other objects to the borders of the page. I have done a few different sizes and they always come out correctly.

  • My page size doesn't change compared to the visual border of the page that I see in Composer. Sounds like there is something not working correctly for me.
    – cndnflyr
    Nov 21, 2017 at 17:12

It sounds like your print composer is behaving abnormally. Normally when you change the size of the page in the print composer, the map and other items stay the same size and the page outline gets larger.

Before (page size is 8.5x11): enter image description here After (page size changed to 11x17): enter image description here

Possible solutions, in order of increasing inconvenience:

  • Save project, close QGIS, reopen project.
  • Turn computer off and back on again.
  • Borrow a friend's computer.
  • Create a new print composer. Set the page size to 11x17 before adding a map or any other items. Export the blank page as a PDF and see if the page is 11x17 in Acrobat. If so, re-create the original print composer in the new print composer.
  • Create a new, blank project and see if print composer behaves normally. If so, re-create the original project, testing the composer occasionally to make sure the problem doesn't re-occur.
  • Update to the latest version of QGIS. If you already have the latest version, re-install it.
  • Submit a bug report. Wait for someone to fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.