2

I'm programming a plugin for Qgis 2.18 and everything worked fine, until we tried open the plugin from another computer.

On the second computer (same Qgis version) the plugin is unable to open the qgs-project files. After a lot of searching we determined that QGIS is able to open them, if within the xml-file of the qgs-project we change the type from type="plugin" to type="raster". Yet, the changed projects do not work on the first computer anymore after the change. Everything else has remained the same.

The .qgs files possess only the layer in which the map itself (generated from an osm map) is shown.

.qgs project on computer 1:

    <maplayer minimumScale="0" maximumScale="1e+08" type="plugin" hasScaleBasedVisibilityFlag="0" name="PyTiledLayer">

.qgs project on computer 2:

    <maplayer minimumScale="0" maximumScale="1e+08" type="raster" hasScaleBasedVisibilityFlag="0" name="PyTiledLayer">

Does anyone know why this happens and what exactly the type is?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.