I have converted a raster to a polygon, dissolved the polygons into singlepart, and tried to calculate areas using Calculate Geometry. Many of the areas are 'zero' or are areas that are obviously not correct.

How can I fix this?

When I calculate the areas for the undissolved polygons they appear to be correct. They are just subdivided into grid cells with the same spatial resolution as the Landsat image from which they are derived (30m x 30m). So, one grid cell has an area of 900 sq meters. The problem is that I need the grid cells dissolved so I can determine the exact number of polygons and their respective areas, hence the use of the dissolve tool.

The defined projection is WGS UTM Zone 9N (the same as the Landsat image) and it has never been changed.

  • 1
    Try repair geometry resources.arcgis.com/en/help/main/10.2/index.html#//….. the area calculation fails on non-simple geometries which could be why you're having problems. If that doesn't help calculate the areas in the undissolved polygons then dissolve resources.arcgis.com/en/help/main/10.2/index.html#//… with a sum of area field. Commented Nov 22, 2017 at 0:55
  • Hi Michael, Thanks for your reply. Repair geometry does not seem to make a difference. I calculated areas for the undissolved polygons, then dissolved by the Area Field sum as you suggested, but it just assigns the sum of all of the areas to all of the polygons (so, they all have exactly the same area). Thoughts? Commented Nov 22, 2017 at 1:23
  • Did you specify your dissolve field so that not all polygons were made into one polygon? I'm assuming you have polygons with different values that you want to maintain but as an aggregate area of the same values. Commented Nov 22, 2017 at 1:27
  • I did not specify any dissolve field, just the Statistic Field with Area as the chosen field and Sum as the chosen statistic. This results in separate polygons (as desired), but all with the same value for Area (which is not correct). Commented Nov 22, 2017 at 1:38
  • Would it help for you to see the shapefiles? I can provide them. Commented Nov 22, 2017 at 1:39

1 Answer 1


Unfortunately I cannot comment, so will add an answer. I downloaded your information, and have seen your initial data and your dissolve. Can I ask why you do not recalculate the areas of your dissolved polygons after the dissolve?

Create a field called dissolved area and run the "Calculate Geometry" on that field by right-clicking and selecting it from the context window that appears.

If I have missed the boat, I apologise and will delete this answer.

  • Hi Keagan, This is what I tried to do initially but the geometries calculated after the dissolve were not correct, hence my post here. Thanks for your reply! Commented Nov 22, 2017 at 14:15
  • I downloaded the data as well and I have to agree with Keagan, the Calculate Geometry is giving accurate results, they might just be unexpected results. A couple things to try- did you use the Simplify Polygons option in the Raster to Polygon tool? Also, your area field is a Long, try making it a Float and you will see that the polygons with 0 area are being rounded down
    – GISUser9
    Commented Nov 22, 2017 at 16:08
  • Yes I've gotten it sorted out now. The issue was that I was not dissolving the correct field. Now, once I dissolve by the Area Sum I can just recalculate the geometries and they are correct. Thanks for your help! Commented Nov 22, 2017 at 17:17
  • @BrittneyG. glad it worked out! Commented Nov 22, 2017 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.