3

I have several Layers published On Geoserver 2.12.1. These are properly organized in Workspaces.

I want the WFS to work on 2 of the Workspaces, but not serve out the data from one Workspace. WMS should work with all layers in all Workspaces. (like it is working currently)

I've tried several things, but I have not been able to lock down the WFS only on one Workspace.

Things I have tried:

  1. Go to WFS Under Services in the Left hand panel. Then select the workspace, and uncheck 'Enable WFS'.

enter image description here

This does not seem to affect anything.

  1. Go to WFS Under Services in the Left hand panel. Then not select any workspace in the dropdown, and uncheck 'Enable WFS'. This seems to disable all WFS services.

How to Disable WFS on a specific WorkSpace in Geoserver?

4

You need to turn off WFS for all services under the main WFS menu

enter image description here

and then turn it on by setting Enable WFS for the workspaces that you want to allow it for.

enter image description here

4

Ian Turton's answer is exact but INCOMPLETE!

After enabling the desired OGS Services at Workspace level (in Edit Workspace), you have to:

  • go back into the main WFS menu and
  • from the Workspace dropdown you have to select the Workspace you want to serve as WFS
  • and check 'Enable'
  • then don't forget to press Save button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.