1

I am trying to calculate nearest neighbor using the NN-Join add-in. This has worked well until now, but after I updated my data it only partly works.

I have a point layer, and I have three other layers, two point layers and one polygon layer, and I need to calculate the distance to the nearest point in the joint layers, and in the polygon layer to the nearest polygon.

My input layer (point) is in a geographic CRS (EPSG: 4326, WGS 84), and all my join layers are in a projected CRS (EPSG: 32633, WGS 84/UTM zone 33N). This used to give me the distances from the nearest features in the join layers in meters without errors.

Now, after having updated the data, and running the same procedures over again, this works fine with two of the point layers, but on the last point layers, the program aborts ("qgis-bin.exe has stopped working"), and with the polygon join layer the distances are 0 (zero), except for a few records (37 of 3723) where I get the correct distances. In the last case I haven't been able to find any system in the manner how the procedure returns the correct distances in ca 10% of the cases.

I have tried to reinstall QGIS (version 2.18.14). I had version 2.18.x previously as well, but probably not 2.18.14. I have juggled CRS's, I have read point data in over again, but the errors seem to be consistent.

Any help out there?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.