2

I have an issue trying to symbolise a layer with graduated symbols using a custom expression:

  1. I am limited to using arcade/there are no other languages in the drop down which I don't believe should be the case.
  2. An arcade custom expression, even $feature['FieldName'], is producing correct values/band but the corresponding labels have 6 decimal places appended where using the field alone (no custom expression) is not. No casting and/or round, trim or replace etc will fix this.

I am using ArcGIS Pro 2.0.1.

I can manually edit the labels but any changes I make to symbology will bring back the decimal places.

0
2

In your symbology pane, click the hamburger icon in the top-right corner and select Advanced

enter image description here

In the advanced symbology settings pane uncheck "Pad with zeros", and then click the back arrow.

enter image description here

Your labels should now be without all the extra decimal places.

enter image description here

The default number of decimal places appears to be 6. If you do still want to see some decimals, but less than 6, go back into the Advanced settings, set your Rounding > Decimal places to another number, e.g. 2, and leave Pad with zeros checked, your labels should now be padded with only 2 decimal places.

enter image description here

0
1

The 'Advanced' menu isn't available for Labels. Here's an expression that can be used for them using Round():

Round($feature.fc_field_name, 3)

Round(value, numPlaces?) -> returns: Number

Source: https://developers.arcgis.com/arcade/function-reference/math_functions/

1
  • When I refer to labels, I mean the labels for each band in a graduated symbology. As I mentioned in my question, rounding doesn't help as the values have no decimal places, the symbology bands are padding the values with decimal zeros. The accepted answer is correct, although the option location has changed recently. – BlueTalon Dec 6 '18 at 22:22
0

The accepted answer is still correct, but the location of the advanced options for symbology has changed slightly. It is no longer in the symbology options menu, but is now a tab icon.

Symbology advanced options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.