1

Context

We're now in the process of transferring our systems to Qgis.

what needs to be done

I need to export a DXF based map from Qgis into vector pdfs, in order to import into the program we use for illustrations.

For additional info : Qgis is not able to do what I need it to do for an illustration.

Problem

After some experimentation this seems to be impossible if I have the print composer zoomed out to 1:500 or greater. This value appears to be not constant. Different data is giving different sizes.

If I'm zoomed in, the pdf exports as a vector, but if I'm zoomed out, it's a raster even though I've unchecked everything I can find that controls when to export to raster.

Question

Can anyone tell me how to get the software to export a vector map at a scale of, for example, 1:10000?

**Further info : workflow **

  • Export as pdf.

  • Open pdf in word 2016 and save as word.doc.

  • Select image, bring to front of text.

  • Then ungroup.

  • The smaller images break into drawing objects at this point. The rasters, obviously, don't.

This is actually easier than getting emfs in from our old GIS program, believe it or not. Or rather, it is if they export as vector pdfs reliably. I'm guessing that there is a resolution setting somewhere that may govern this.

I've tried changing linewidth to zero with no luck. I've tried altering output dpi to 600 and I tried changing main properties from cache to render.

edit - I wonder if there is something that restricts the number of objects which can be in a pdf and automatically saves to raster if that limit is reached?

  • What layer types are you trying to export? – DPSSpatial Nov 28 '17 at 15:18
  • The effect seems to be variable. I was only exporting from a dxf map which was created originally from an NTF. I don't know what you mean by layer types. When I just now added a small dxf and set composer to 1:1000, it exported as a vector pdf. I've been able to import and ungroup that one. The one of the whole village, however, stubbornly remains a raster, even if I turn off everything except the grid itself (which I added using composers grid controls.) I can't work out what variable is making the difference. – PJ Lightning Nov 28 '17 at 15:24
  • 1
    Is your illustration program capable of handling SVGs? That's what i would normally export to if I was doing additional vector editing, rather than a PDF. – Ed Rollason Nov 28 '17 at 15:28
  • 1
    Also under layer properties -> rendering there is a new tick box option to force rendering as raster. That was a new one to me. That isn't ticked is it. – Ed Rollason Nov 28 '17 at 15:28
  • No it can't. We will be switching to one that can, possibly, eventually, but at the moment the only vector file, that Qgis will export, that I can import is pdf. I may as well 'fess up, that we're using Word. – PJ Lightning Nov 28 '17 at 15:29
2

When you export your map as a PDF, make sure you have un-ticked the Print raster box in the Composition properties. But that's not the only place (see below).

print raster

There's another box to untick when you export as PDF, you might get this error message with often a big window with a little tickbox at the bottom. Make sure this second box is also un-ticked or it will switch back to raster export.

composition effects

  • I already did those things. ie both were unticked every time. It makes no difference. It does look like there may be a restriction based on number of drawing objects. I tried your suggested svg settings but although the svg looks right if I just click on it and look at it in a browser, when I open it in Inkscape, the objects are outside the map frame. Thank you for taking the time to try various things. – PJ Lightning Nov 28 '17 at 17:01
  • No problem, i'm mainly trying to make it easy to follow the answers. Make sure you comment the right answer. I'm thinking maybe something is specific to your drawing, because I had a try and i didn't have those problems on my Senegal scale map (1:3 000 000), but all my object where within the map. – gisnside Nov 28 '17 at 17:12
  • Sorry, I'm used to linear forums, not ones with sub-threads. It looks as if I'll have to crop the map in CAD first and then match the composer frame to that. It's not a big issue with the OSmap, but it's going to be one heck of a problem when we start working on the larger site excavations. QGIS doesn't create publication standard figures. – PJ Lightning Nov 28 '17 at 17:18
  • No problem, i come from there too but I got used to Q&A, it's a little different but nice. I added another suggestion after the comments of your question. – gisnside Nov 28 '17 at 17:19
1

You could try a SVG export, readable by inkscape (free !) or illustrator. It's supposed to be vector in this specific format. You can then reconvert it back to other vector formats that could be read by Word at the end.

svg export

I used the following setup and it worked properly in my case :

export window

  • Fairly long-winded way to do it, but it seems I have no choice. SVG seems to add a lot of extra blank polygons, though. – PJ Lightning Nov 28 '17 at 16:33
  • Just tried it. No good. The SVG exported a load of things that were outside the print composer window. – PJ Lightning Nov 28 '17 at 16:36
  • You could use the box "crop to content" maybe ? – gisnside Nov 28 '17 at 16:40
  • Tried. Didn't crop. – PJ Lightning Nov 28 '17 at 17:18
1

The answer to this turned out to be that the rasterising problem was (and is) on Word's end and not a problem with QGIS. If the image has too many objects Word will rasterise it and there's no altering that.

In order to get the data into Word in a vectore format, I must open the pdf in Corel Draw and then save the ojects as a metafile.

Inkscape fails to clip to the frame, whether importing svg or pdf as soon as I ungroup, I have objects outside the frame. In Corel, the objects are clipped to the frame when I open the pdf. So Corel is the program I'm going to be using for now.

Note to anyone doing this in Corel - do not use any partial transparency in QGIS and do keep lines thin and continuous. Corel will not import thick lines or broken lines correctly. You can add those styles later in Corel if needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.