1

I have a number of addresses that I would like to map as point data (along with attributes) in QGIS. I got the GPS coordinates from Google Maps, but when I create the layer from the table, the points are way off. I have just copied and pasted the GPS coordinates from Google maps into a spreadsheet. See image below.

enter image description here

They should be located around Salinas, CA, USA not off the coast of Africa. I have tried using different Coordinates Reference Systems, for example: Google Mercator, NAD83(CSRS), NAD83, WGS 84 / Simple Mercator, WGS 84 / Pseudo Mercator. I am using the Google Maps base layer from the open layer plugin, yet none of these project the points where I would like them to be.

Is it the format of the GPS coordinates?

Or I am totally using the wrong Coordinates Reference System?

  • You missed the obvious CRS: EPSG:4326 WGS84. – AndreJ Dec 9 '17 at 14:05
1

There is an issue regarding OpenLayers plugin in QGIS. Try to use QuickMapServices Plugin instead. Since you have the data in Excel format, save it as CSV file and load the data using Add Delimited Text Layer in QGIS as follows:

enter image description here

By default, it will use WGS 84 geographic spatial reference since your data is geographic.

Save the data as shapefile with WGS 84 / Pseudo Mercator (EPSG:3857) because you will use it with QuickMapServices Plugin Plugin which uses the same projection.

enter image description here

Load the shapefile point data created above with QuickMapServices Plugin and it should work properly.

Here is the output using a sample from your data with the correct location around Salinas:

enter image description here

  • Hi Ahmadhanb! Thank you for your suggestion, I tired using QuickMapServices but it made no difference. – Roxanne Lloyd Nov 30 '17 at 6:37
  • I updated my answer. – ahmadhanb Nov 30 '17 at 9:10
  • I followed your instructions above and it still didn't make a difference, my points are still off the coast of Africa. I am running the latest version of QGIS on a Mac, could that have something to do with it? – Roxanne Lloyd Dec 1 '17 at 1:31
  • Did I need to convert my lat and long into another format? – Roxanne Lloyd Dec 1 '17 at 3:14
  • 1
    It works even without saving to shapefile, just make sure the CSV LAYER CRS is EPSG:3246, PROJECT CRS set to EPSG:3857 and On-the-fly-reprojection is enabled. – AndreJ Dec 9 '17 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.