1

I am trying to connect an PostgreSQL database made using pgAdmin 4 in ArcGIS Pro 2.0.1. PostgreSQL version is 10.0.

I tried several methods of connecting and how easy it is in QGIS I cannot find the reason why it doesn't work in ArcGIS Pro.

I followed the steps here, edited the pg_hba.conf file even by making so all connections to the database are allowed thinking this would be the issue but this didn't help.

I am configuring it like this now:

Database connection in ArcGIS pro

Where my database name in PGAdmin is this:

PGAdmin database list

I am using regular settings:

host name: localhost port: 5432 username: postgres

But yet, whatever I try, this error pops up:

Error message

What I am doing wrong? This is my first time doing it on ArcGIS Pro and I didn't have any problems using other software.

6
  • 1
    Do not ever use the postgres user for trivial connection tests. Proper practice is to create a minimally privileged login (e.g. "test" or "proj1user"). You may be using an unsupported PostgreSQL release -- please edit the question to specify the exact PG version. Your problem is likely that your connection parameters are different -- localhost is not the same as vrowl (you must take proactive steps to permit connection on other than the loopback interface)
    – Vince
    Commented Nov 30, 2017 at 11:35
  • 2
    PostgreSQL 10 is not yet supported by any Esri release. pro.arcgis.com/en/pro-app/help/data/databases/…
    – Vince
    Commented Nov 30, 2017 at 12:33
  • Well that explains it then. Thanks for the answer. Any indication when this will be supported?
    – B.Quaink
    Commented Nov 30, 2017 at 13:23
  • 10.6 is due out soon; it will likely support 9.6, but I'm not convinced 10.0 will make the cut.
    – Vince
    Commented Dec 1, 2017 at 3:31
  • I am having the same problem, using the 9.6 version of PostgreSQL and 2.1.3 have gone through same channels/processes as user stated above
    – Grace
    Commented May 31, 2018 at 12:41

1 Answer 1

2

User Vince answered this:

PostgreSQL 10 is not supported by any Esri releases.

http://pro.arcgis.com/en/pro-app/help/data/databases/database-requirements-postgresql.htm

Requirements for the current version (2.1):

https://pro.arcgis.com/en/pro-app/help/data/geodatabases/manage-postgresql/database-requirements-postgresql.htm

Still no PostgreSQL 10 sadly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.