1

I have issues with a normal join of two layers. The first set consists of a large list (n=259102) and I need to pick out 56 objects from this list. For that I have a second list with the 56 object IDs which are consistent with an ID field in the first list, as is pointed out here.

My first issue was that the two fields containing ID was in different formats, so i have tried changing the type in my smaller list using the field calculator. The way I did this is just creating a new field with the right type and then copying my ID in to that new field, as is suggested here.

But now to the issue. When i try to join these to layers I only get null fields in the large list and my objects are not picked out. When i look in the smaller list, my new IDs are all null as well. This was not the case when I first looked at the attribute table and it seemed to have changed during the join. I have saved the edit before i did the join, so that should not be the issue.

Is this an issue that anyone else has encountered and has a solution to?

I'm using QGIS 2.18.13.

  • An update on my issue.I have tried doing the calculations on the smaller list and then using "save as" but this also generates null values in the new column with IDs so the issue seems to be with the calculator. Is there any other tools i can use to do this kind of conversion? – Kristoffer Hellberg Dec 8 '17 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.