3

I come from a GIS background mainly using ArcMap and QGIS, but am now doing more image processing work and so have decided to start using ERDAS IMAGINE 2013.

I am attempting to project a shapefile from WGS 1984 to British National Grid.

I open the shapefile, and it displays fine:

]

From the vector tab, I select "Reproject shapefile". For the input file I select this shapefile I opened, however I get the error "Fail to convert string to coordsys obj." Googling this error produces no results. The source projection fields are not filled, and I cannot reproject the shapefile:

Examining the metadata for the shapefile, I notice the projection tab is blank:

Selecting Edit -> Add coverage projections (I assumed this was a way of defining the projection for the layer), I select Edit Projection Parameters, and then select WGS 84 and Decimal Degrees. I select Yes overwrite PRJ file, then get the error message "Faled to translate erdas map projection to PE coordsys.", which again brings up no results in Google.

ERDAS seems to be unable to read projection information for my shapefiles, or possibly unable to read the .prj files. Watching this video using an older version of ERDAS: https://www.youtube.com/watch?v=Vfk4eOJ92xw the process seems straightforward enough, but I've tried various shapefiles from different sources, and new shapefiles made in Arc and QGIS, and get the same error. I've managed to reproject raster data fine.

I can reproject the shapefiles fine in ArcMap, but like I said I'm trying to get used to ERDAS as much as I can.

Is there a step I'm missing somewhere?

  • 1
    Welcome to GIS StackExchange.If this is the first time you are encountering this issue, it may be a problem with the IMAGINE install. It has some "one time configuration" tasks that auto-run during installation that deals with coordinate system files etc. Have you tried an installation repair or clean reinstall? – cm1 Dec 1 '17 at 15:13
  • @cm1 Thank you for the welcome. I'm on a pretty locked down work PC so can't reinstall myself, but trying out the same tasks on a different workstation I'm not getting the errors, so yes looks like an install problem. Thank you for the suggestion. :) – ThomasMNS Dec 2 '17 at 12:08
1

I also experienced similar problem. To solve this problem, I followed the following steps.

i. ArcGIS>ArcToolbox>Data management tools>Projection and transformation ii. From Projection and transformation>define projection> Define projection has two parameters and they are input shape file and coordinate system.

iii.Drag and drop your shape file in the input shape file box iv. Select your coordinate system.

As I worked with Dhaka, I used wgs 1984 for as the coordinate system. I think you can try with wgs 1984 coordinate system.

After completing these steps, open the file in erdas imagine and follow the steps for creating aoi file.

I hope you will get success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.