1

I'm not sure if this can be done, but I am using QGIS (2.8) and the wonderful Atlas composer, and what I would like to be able to do, is stop labels from being 'cropped' by the atlas generator (Example below). Example of text cropping off edge of map

I know this goes against the purpose of an atlas creation ( in that there should be overlap so you can navigate from one map to the next), but is there a way to stop this from happening?

  • If you like the atlas composer in QGIS 2.8, you'll love the many new features available in 2.18. Basically every style setting can be set using data-defined override. Using variables like @atlas_feature, any style setting can be dependent on which page of the atlas it's on. – csk Dec 15 '17 at 19:35
4

One solution is to use wordwrap() in labeling the field and increase the number of lines to three instead of two. You can use wordwrap() as follows:

 wordwrap(  "Fieldname" ,number)         # example:  wordwrap(  "Name_2" ,5)

where:

Fieldname is the name of the target field, and Number is the desired length of characters to wrap the string

enter image description here

You should place it under Label with as in the following image:

enter image description here

Another solution is to uncheck Show Partial label from the labeled layer by going to the Layer Properties -> Click on the icon at the upper right :

enter image description here

Uncheck Show Partial label.

enter image description here

I am afraid it will remove completely the label which is partially rendered, but you can give it a try, it may solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.