2

When I create a query layer, the attribute table has 1004 records. When I attempt to export this data to a file geodatabase, it only has 523 records. I have tried exporting to a personal geodatabase, a shapefile, and also using Copy Features to export the data, each time only 523 records are exported.

What is going on?

When exporting to a geodatabase or using copy features tool, there is no error message. Only when I export to a shapefile, do I get three separate pop up windows:

  1. Error exporting data Error reading some rows from the source. These rows have not been converted.
  2. Warning: Some records may not have been exported correctly.
  3. There was an error exporting the layer.

I have managed to export many features successfully, but there appears to be a few tables that struggle with this.

I'm new to this type of work.

As a note, there are no joins or selections on the query layer when I attempt to perform the export. I am using ArcMap 10.4.1.5686, Advanced License.

closed as unclear what you're asking by PolyGeo Jan 22 '18 at 4:38

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Have you tried running a repair geometry on a copy of your layer? – johns Dec 5 '17 at 17:34
  • Hi Johns, thank you for your question. I have not tried doing this because I must export it to the geodatabase first in order to do so. By the time the layer is exported to the geodatabase, those features have been removed. – Diane_999 Dec 6 '17 at 17:41
  • Where is the data stored that you are creating this query layer on? – PolyGeo Dec 6 '17 at 22:38
  • An oracle database. – Diane_999 Dec 7 '17 at 18:29
  • 1
    Have you examined in detail one feature that goes missing during your export? Is it tiny, does it self-intersect, etc? – PolyGeo Dec 12 '17 at 5:35